This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 10962 - specific options in /etc/rpmrc are not recognized
specific options in /etc/rpmrc are not recognized
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-21 04:48 EDT by jruddell
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 18:26:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jruddell 2000-04-21 04:48:29 EDT
After created a .rpmrc file following the RPM_HOWTO I get the
following errors running rpm

bad option 'require_vendor' at /root/.rpmrc:1
bad option 'distribution' at /root/.rpmrc:2
bad option 'require_distribution' at /root/.rpmrc:3
bad option 'topdir' at /root/.rpmrc:4
bad option 'vendor' at /root/.rpmrc:5
bad option 'packager' at /root/.rpmrc:6
bad option 'signature' at /root/.rpmrc:12
bad option 'pgp_name' at /root/.rpmrc:13
bad option 'pgp_path' at /root/.rpmrc:14
bad option 'tmppath' at /root/.rpmrc:16

using rpm version 3.0.4

using the follwing .rpmrc
require_vendor: 1
  distribution: I roll my own!
  require_distribution: 1
  topdir: /usr/src/me
  vendor: Mickiesoft
  packager:  Mickeysoft Packaging Account <packages@mickiesoft.com>

  optflags: i386 -O2 -m486 -fno-strength-reduce
  optflags: alpha -O2
  optflags: sparc -O2

  signature: pgp
  pgp_name: Mickeysoft Packaging Account
  pgp_path: /home/packages/.pgp

  tmppath: /usr/tmp
Comment 1 Jeff Johnson 2000-05-08 18:26:59 EDT
The configuration of rpm has changed since "Maximum RPM". For your example,
put in /root/.rpmrc
   optflags: i386 -O2 -m486 -fno-strength-reduce
   optflags: alpha -O2
   optflags: sparc -O2

(Note: the above are the default rpm values, there's no reason to configure)

and the following in /root/.rpmmacros:

    %distribution   I roll my own!:
    %_topdir        /usr/src/me
    %vendor         Mickiesoft
    %packager       Mickeysoft Packaging Account <packages@mickiesoft.com>

    %_signature     pgp
    %_pgp_name      Mickeysoft Packaging Account
    %_pgp_path      /home/packages/.pgp

    %_tmppath       /usr/tmp

(Note: there are no analogues of require_vendor/require_distribution)

Note You need to log in before you can comment on or make changes to this bug.