Bug 1096223 - Undefined method session when default organization set
Summary: Undefined method session when default organization set
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
: 1095291 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-09 13:36 UTC by Eric Helms
Modified: 2016-04-26 00:56 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-07-02 14:07:06 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 5645 None None None 2016-04-22 15:42 UTC

Description Eric Helms 2014-05-09 13:36:54 UTC
<pre>
NameError: undefined local variable or method `session' for Foreman::Controller::UsersMixin:Module
 | /home/ehelms/workspace/foreman/app/controllers/concerns/foreman/controller/users_mixin.rb:60:in `block in set_current_taxonomies'
 | /home/ehelms/workspace/foreman/app/controllers/concerns/foreman/controller/users_mixin.rb:55:in `each'
 | /home/ehelms/workspace/foreman/app/controllers/concerns/foreman/controller/users_mixin.rb:55:in `set_current_taxonomies'
 | /home/ehelms/workspace/foreman/app/controllers/concerns/foreman/controller/authentication.rb:77:in `set_current_user'
 | /home/ehelms/workspace/foreman/app/controllers/concerns/foreman/controller/authentication.rb:18:in `authenticate'
</pre>

Comment 1 Eric Helms 2014-05-09 13:36:56 UTC
Created from redmine issue http://projects.theforeman.org/issues/5645

Comment 2 Eric Helms 2014-05-09 13:37:01 UTC
Upstream bug assigned to ehelms@redhat.com

Comment 6 Dominic Cleal 2014-05-20 15:01:30 UTC
*** Bug 1095291 has been marked as a duplicate of this bug. ***

Comment 9 Tazim Kolhar 2014-05-26 07:32:26 UTC
Please provide verification steps

Comment 10 Eric Helms 2014-05-27 12:58:34 UTC
Steps to verify:

1. Create a new user
2. Give that new user an organization and set a default organization afterwards
3. Hit the API as that user

Comment 11 Tazim Kolhar 2014-05-27 14:31:28 UTC
VERIFIED

Comment 12 Bryan Kearney 2014-07-02 14:07:06 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.