Bug 109623 - Bug in workspace-grid.jl
Bug in workspace-grid.jl
Status: CLOSED DUPLICATE of bug 120652
Product: Fedora
Classification: Fedora
Component: libwnck (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 08:40 EST by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2003-11-10 08:40:55 EST
Description of problem:
When the "Send window to the workspace left/right/up/down" function
is used, it changes the location of the window relative to the
workspace origin. This is a bug in the workspace-grid.jl script.

Version-Release number of selected component (if applicable):
1.3-2

How reproducible:
100%

Steps to Reproduce:
1. Use sawfish-ui to bind (for example) ctrl-alt-right to the
"send window to the workspace right" function
2. Press ctrl-alt-right over some window to move it to the right
workspace.
  
Actual results: window is sent to the next workspace, however it does
not stay in the same position relatively to the workspace origin.

Expected results:
The window is sent to the workspace to the right, but it should stay
on the same position relatively to the workspace origin.

Additional info:
Using diff -u to the workspace-grid.jl which I had on RedHat 9 i
figured out that the following patch helps:

--- workspace-grid.jl.orig      2003-10-22 00:08:05.000000000 +0200
+++ workspace-grid.jl   2003-11-10 14:32:47.000000000 +0100
@@ -221,6 +221,9 @@
              (when (= (aref (caddr layout-property) 0) 1)
                (swap cols rows))

+             ;; Swap layout again because of libwnck bug
+             (swap cols rows)
+
              (if (= rows 0)
                  ;; Compute rows from colums and num-workspaces
                  (let ((total (num-workspaces)))
Comment 1 Jan "Yenya" Kasprzak 2003-11-19 12:20:55 EST
Well, this is in fact a bug in libwnck (see the bug id #109624 as well).
Installing the patched libwnck (patch at
http://bugzilla.gnome.org/showattachment.cgi?attach_id=21124) fixed
the problem for me as well.

I have built fixed RPMs of libwnck -- you can grab the source RPM
and i386 binary RPMs at
ftp://ftp.linux.cz/pub/linux/people/jan_kasprzak/libwnck
(be sure to check the GPG signature against GPG key ID 1024R/D3498839).

Component changed from sawfish to libwnck. Fedora people, please
incorporate this to the next release and close the bug.
Comment 2 Mark McLoughlin 2004-07-27 04:26:20 EDT

*** This bug has been marked as a duplicate of 120652 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.