Bug 109627 - ATI 340M - ATI and VESA driver only support 800x600
ATI 340M - ATI and VESA driver only support 800x600
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 09:25 EST by Andy Blyler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-18 14:55:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of 1024x768 while using radeon driver (497.05 KB, image/png)
2003-11-10 10:19 EST, Andy Blyler
no flags Details
XF86Config File (3.08 KB, text/plain)
2003-11-10 10:20 EST, Andy Blyler
no flags Details
XFree86 log file (29.53 KB, text/plain)
2003-11-10 10:21 EST, Andy Blyler
no flags Details

  None (edit)
Description Andy Blyler 2003-11-10 09:25:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Using RedHat 9 with the VESA and ATI driver I could obtain a 1024x768
resolution.  But now that I installed Fedora the video flakes out when
I try to up the resolution to 1024x768.  This is on the same laptop:
Compaq Evo N1020v

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
    

Additional info:
Comment 1 Mike A. Harris 2003-11-10 09:40:01 EST
The "vesa" driver is limited to whatever the VESA BIOS permits,
and any problems that occur while using the "vesa" driver are
thus only fixable by downloading a new video BIOS.  As such,
since we are unable to fix bugs in ROM BIOS firmware, we do not
support the "vesa" driver.  It is provided solely as a convenience
to end users to be able to try to get some kind of working video
instead of nothing at all.

The "radeon" driver is the proper driver to use with Radeon IGP
hardware.  Note that Radeon IGP is not supported at all by
XFree86 4.3.0 as released by XFree86.org.  The Red Hat radeon
driver contains experimental support patches for Radeon IGP
which work for some users and may not work for other users.

If you attach your X server config file and log file after
configuring it with "redhat-config-xfree86 --reconfig" to use
the "radeon" driver, I can have a look and see if there is any
obvious problems that jump out at me, however I do not personally
have Radeon IGP hardware to test with, so I may not be able
to do much about this problem.

XFree86 4.4.0, which will be released in late December or early
January or so, will be the first XFree86 release to officially
support the Radeon IGP.  If we're unable to figure this problem
out, you may wish to try 4.4.0 when it is released.  I'll be
building rpms of it within a month or so.

TIA
Comment 2 Andy Blyler 2003-11-10 10:19:23 EST
Created attachment 95873 [details]
Screen shot of 1024x768 while using radeon driver
Comment 3 Andy Blyler 2003-11-10 10:20:34 EST
Created attachment 95874 [details]
XF86Config File
Comment 4 Andy Blyler 2003-11-10 10:21:12 EST
Created attachment 95875 [details]
XFree86 log file
Comment 5 Mike A. Harris 2003-11-10 12:58:31 EST
Hmm, your screenshot is 1024x768, however your config file and
log file are 800x600.  Please reconfigure it to use 1024x768,
and run the X server again, and attach the log file and config
file from the new run.  That should provide me with some clues
as to what the problem might be.

TIA
Comment 6 Andy Blyler 2003-11-10 13:23:30 EST
Okay, this is making more sense now.

The reason why my display was so messed up was I ran
`gnome-display-properties`.  Which allowed me to choice 1024x768 as a
resolution even though my XF86Config file wasn't set up for it.  I am
going to research this further.

To resolve the issue:

I reconfigured it, and selected my monitor (since it is a LCD and
wasn't auto detected).  And then selected ATI Radeon (Generic). Then I
had to go back to the first tab and select 1024x768.

It seems a little awkward that you have to go back to a previous tab,
maybe they need to be reworked.
Comment 7 Mike A. Harris 2003-12-18 14:55:08 EST
Closing bug as NOTABUG, since it seems it was just a configuration
issue.

Note You need to log in before you can comment on or make changes to this bug.