Bug 109643 - LTC5309 - Failed to install RHEL with method=nfs:SERVER:/PATH
LTC5309 - Failed to install RHEL with method=nfs:SERVER:/PATH
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 112135 113479
  Show dependency treegraph
 
Reported: 2003-11-10 10:53 EST by Olof Johansson
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:39:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch_5309 (637 bytes, text/plain)
2003-11-13 14:27 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description Olof Johansson 2003-11-10 10:53:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031020

Description of problem:
Hardware Environment:
pSeries

Software Environment:
RHEL3 GM version

Steps to Reproduce:
1. Setup a NFS service which exports the RHEL3 GM isos. In the
following, we 
use 172.30.1.170:/RHELGM for this service.
2. Boot the pSeries by CDROM
3. At the yaboot prompt, type the following:
   "linux method=nfs:172.30.1.170:/RHELGM"

Actual Results:
   The installation program exit abnormally. 
on /dev/tty1 :
       install exited abnormally -- received signal 11
       sending termination signals ... done
       sending kill signals ...done
       disabling swap ...
       umounting filesystem ... 
       /mnt/runtime done
       disabling /dev/loop0 /mnt/source2 done
       disabling /dev/loop1 /proc done
       /dev/pts done
       /tmp/ramfs done
       /mnt/source done

       you may safely reboot your system.
on /dev/tty3:
       hosts is 172.30.1.170 , dir is /RHELGM
       mounting nfs path 172.30.1.170:/RHELGM
       mounted 172.30.1.170:/RHELGM on /mnt/source
       mntloop loop7 on /tmp/loopimage as
/mnt/source/rhel-3-ppc-as-disc1.iso 
fd is 17
       umounting loopback /tmp/loopimage loop 7
       path to valid iso is /mnt/source/rhel-3-ppc-as-disc1.iso
       mntloop loop1 on /mnt/source2 as
/mnt/source/rhel-3-ppc-as-disc1.iso fd 
is 16
       mntloop loop0 on /mnt/runtime as
/mnt/source2/RedHat/base/stage2.img fd 
is 16
       mntloop loop7 on /tmp/product-disk 
as /mnt/source2/RedHat/base/product.img fd is 16
       recursively copying /tmp/product-disk/lost+found
       recursively copying /tmp/product-disk/installclasses
       recursively copying /tmp/product-disk/pixmaps
       umounting loopback /tmp/product_disk loop7


Expected Results:
   Install the RHEL correctly.

Additional Information:
   When type "linux method=nfs", and then input the server, NFS share
path, we 
can install RHEL without any problem.

   When type "linux method=http://172.30.1.170/redhat" or "linux 
method=ftp://USER:PASSWORD@172.30.1.170/RHELGM" , we can also install
RHEl 
without problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above

Additional info:
Comment 1 IBM Bug Proxy 2003-11-11 11:55:41 EST
------ Additional Comments From olof@us.ibm.com(prefers email via olof@austin.ibm.com)  2003-10-11 15:46 -------
Over to Service. 
Comment 2 IBM Bug Proxy 2003-11-11 11:56:54 EST
------ Additional Comments From salina@us.ibm.com  2003-10-11 17:21 -------
Glen / Greg / Mark
Over to you to track - RedHat installation problem 
Comment 3 IBM Bug Proxy 2003-11-11 11:57:30 EST
------ Additional Comments From olof@us.ibm.com(prefers email via olof@austin.ibm.com)  2003-10-11 17:45 -------
katzj@redhat.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED
   devel_whiteboard|                            |low priority, maybe U2 
Comment 5 IBM Bug Proxy 2003-11-13 14:27:27 EST
Created attachment 95953 [details]
patch_5309
Comment 6 IBM Bug Proxy 2003-11-13 14:27:55 EST
------ Additional Comments From penghb@cn.ibm.com  2003-13-11 02:51 -------
 
CSDL Fix for bug5309

We did some investigation into the problem and found it is caused by the
mountNfsImage(...) in loader/nfsinstall.c. It failed to free memory for host
and directory.

After we patched the source code, we can successfully install the system by
NFS. 
Comment 7 Jeremy Katz 2003-11-19 16:51:14 EST
Fixed in CVS on HEAD
Comment 8 mark wisner 2003-11-24 22:36:35 EST
------ Additional Comments From khoa@us.ibm.com  2003-24-11 19:55 -------
Fix is available and already submitted to Red Hat -> Move bug report to
Submitted state.  We'll close this bug report once we know when the fix
will be in an official release.

Do we know when this fix will appear in an official release/update ? 
Comment 9 IBM Bug Proxy 2003-12-17 10:34:16 EST
------ Additional Comments From penghb@cn.ibm.com  2003-12-16 21:56 -------
QU1 doesn't incude the patch. And the nfs install still fail. 
Comment 10 IBM Bug Proxy 2004-01-12 01:32:13 EST
------ Additional Comments From penghb@cn.ibm.com  2004-01-12 01:18 -------
It become wrose when trying RHEL3-U1-re0108.0-ppc-as-disc1-ftp.iso. We can not 
continue install when we type "linux method=nfs:172.30.1.170:/RHELGM". We can 
not install RHEL by "linux method=nfs" either.

We also tried "linux method=ftp://USER:PASSWORD@172.30.1.170/RHELGM", "linux 
method=http://172.30.1.170/RHELGM", "linux method=ftp" and "linux method=http". 
All of them failed. Now we can only install by "linux askmethod".

We can not download the newest source code of anaconda. So we can check whether 
the patch is included. 
Comment 11 IBM Bug Proxy 2004-03-18 16:15:31 EST
----- Additional Comments From khoa@us.ibm.com  2004-03-18 16:15 -------
Can you verify now if this patch is included in RHEL3 U1 ? 
Comment 12 IBM Bug Proxy 2004-03-23 07:10:34 EST
----- Additional Comments From bujunhui@cn.ibm.com  2004-03-23 07:11 -------
 In new-released RHEL3 Update2 Beta0316  this defect still exist. 
Comment 13 Larry Troan 2004-04-22 09:26:46 EDT
Jeremy, is the attached patch in a later RHEL3 U2 beta (Glen
Johnsons's comment #12 dated 3/23)? If so, when will the x86, as well
as powerpc, ISOs contain the fix so our IHV partners can verify the fix? 
Comment 16 Jeremy Katz 2004-06-09 15:57:11 EDT
Fixed in CVS for U3 (not this patch, though, different one that was
already present on HEAD)
Comment 19 IBM Bug Proxy 2004-07-13 05:56:44 EDT
----- Additional Comments From bujunhui@cn.ibm.com  2004-07-13 05:55 -------
Great...
In lastest-released RHEL3-U3-Beta-RC-re0709, this defect was fixed.
but there is another problem: 
At the yaboot prompt, type the following: "linux method=nfs", with this method 
the system do the installation using CD-Rom, this isnot as what we expected,  
before I can do installation using this "linux method=nfs" and the installer 
will prompt us to specify ethernet card and NFS server name and directory. 
Comment 20 IBM Bug Proxy 2004-07-19 06:18:02 EDT
----- Additional Comments From bujunhui@cn.ibm.com  2004-07-19 06:14 -------
close this and open a new one(#10075) for "linux method=nfs" error. 
Comment 21 John Flanagan 2004-09-02 01:39:50 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-417.html

Note You need to log in before you can comment on or make changes to this bug.