Bug 109692 - Missing BuildRequires (and the javascript checking the descriptive coefficient of this entry is ridiculous)
Summary: Missing BuildRequires (and the javascript checking the descriptive coefficien...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: Xaw3d   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-11 00:17 UTC by Zenon Panoussis
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-26 19:06:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zenon Panoussis 2003-11-11 00:17:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031008

Description of problem:
Attempting to build from src.rpm ends with

+ export
PATH=/usr/X11R6/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
+
PATH=/usr/X11R6/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
+ xmkmf
/var/tmp/rpm-tmp.5884: line 31: xmkmf: command not found
error: Bad exit status from /var/tmp/rpm-tmp.5884 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.5884 (%build)

The problem is a missing "buildrequires: XFree86-devel" in the .spec
file. 


Version-Release number of selected component (if applicable):
Xaw3d-1.5-18

How reproducible:
Always

Steps to Reproduce:
1. rpm- e XFree86-devel
2. rpmbuild -bb Xaw3d.spec

Comment 1 Ngo Than 2003-11-26 19:06:35 UTC
it's fixed in 1.5-20. Thanks for your report


Note You need to log in before you can comment on or make changes to this bug.