Bug 109698 - magicdev gets into a uniterruptable sleep.
magicdev gets into a uniterruptable sleep.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: magicdev (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 20:53 EST by Victor Bogado da Silva Lins
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 13:52:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Similar logs - without magicdev (3.14 KB, text/plain)
2004-01-27 21:15 EST, Bevan Bennett
no flags Details

  None (edit)
Description Victor Bogado da Silva Lins 2003-11-10 20:53:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
When I try to install a package using the add/replace packacges the
cdroms gets unusable. Magicdev gets into the 'D' (uninterruptable
sleep) state and only a reboot can get it out of this state. 

The system log gets the folloing messages : 

Nov 10 23:03:37 unit0 kernel: hdd: timeout waiting for DMA
Nov 10 23:03:37 unit0 kernel: hdd: timeout waiting for DMA
Nov 10 23:03:37 unit0 kernel: hdd: (__ide_dma_test_irq) called while
not waiting
Nov 10 23:03:37 unit0 kernel: scsi : aborting command due to timeout :
pid 54091, scsi0, channel 0, id 0, lun 0 Test Unit Ready 00 00 00 00 00 
Nov 10 23:03:37 unit0 kernel: hdc: ATAPI reset complete
Nov 10 23:03:47 unit0 kernel: hdd: lost interrupt
Nov 10 23:03:48 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:03:48 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:03:48 unit0 kernel: hdd: drive not ready for command
Nov 10 23:03:58 unit0 kernel: hdd: lost interrupt
Nov 10 23:03:58 unit0 kernel: hdd: request sense failure: status=0x59
{ DriveReady SeekComplete DataRequest Error }
Nov 10 23:03:58 unit0 kernel: hdd: request sense failure: error=0x00
Nov 10 23:03:58 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:03:58 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:03:58 unit0 kernel: hdd: drive not ready for command
Nov 10 23:04:08 unit0 kernel: hdd: DMA interrupt recovery
Nov 10 23:04:08 unit0 kernel: hdd: lost interrupt
Nov 10 23:04:08 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:04:08 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:04:08 unit0 kernel: hdd: drive not ready for command
Nov 10 23:04:19 unit0 kernel: hdd: lost interrupt
Nov 10 23:04:19 unit0 kernel: hdd: request sense failure: status=0x59
{ DriveReady SeekComplete DataRequest Error }
Nov 10 23:04:19 unit0 kernel: hdd: request sense failure: error=0x00
Nov 10 23:04:19 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:04:19 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:04:19 unit0 kernel: hdd: DMA disabled
Nov 10 23:04:19 unit0 kernel: hdd: drive not ready for command
Nov 10 23:04:19 unit0 kernel: hdd: ATAPI reset complete
Nov 10 23:04:29 unit0 kernel: scsi : aborting command due to timeout :
pid 54109, scsi0, channel 0, id 0, lun 0 Test Unit Ready 00 00 00 00 00 
Nov 10 23:04:29 unit0 kernel: hdd: lost interrupt
Nov 10 23:04:29 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:04:29 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:04:29 unit0 kernel: hdd: drive not ready for command
Nov 10 23:04:39 unit0 kernel: hdd: lost interrupt
Nov 10 23:04:39 unit0 kernel: hdd: request sense failure: status=0x59
{ DriveReady SeekComplete DataRequest Error }
Nov 10 23:04:39 unit0 kernel: hdd: request sense failure: error=0x00
Nov 10 23:04:40 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:04:40 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:04:40 unit0 kernel: hdd: drive not ready for command
Nov 10 23:04:50 unit0 kernel: scsi : aborting command due to timeout :
pid 54117, scsi0, channel 0, id 0, lun 0 Prevent/Allow Medium Removal
00 00 00 00 00 
Nov 10 23:04:50 unit0 kernel: hdd: lost interrupt
Nov 10 23:04:50 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:04:50 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:04:50 unit0 kernel: hdd: drive not ready for command
Nov 10 23:05:00 unit0 kernel: hdd: lost interrupt
Nov 10 23:05:00 unit0 kernel: hdd: request sense failure: status=0x59
{ DriveReady SeekComplete DataRequest Error }
Nov 10 23:05:00 unit0 kernel: hdd: request sense failure: error=0x00
Nov 10 23:05:00 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:05:00 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:05:00 unit0 kernel: hdd: drive not ready for command
Nov 10 23:05:00 unit0 kernel: hdd: ATAPI reset complete
Nov 10 23:05:10 unit0 kernel: hdd: lost interrupt
Nov 10 23:05:10 unit0 kernel: end_request: I/O error, dev 16:40 (hdd),
sector 412
Nov 10 23:05:11 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:05:11 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:05:11 unit0 kernel: hdd: drive not ready for command
Nov 10 23:05:21 unit0 kernel: hdd: lost interrupt
Nov 10 23:05:21 unit0 kernel: hdd: request sense failure: status=0x59
{ DriveReady SeekComplete DataRequest Error }
Nov 10 23:05:21 unit0 kernel: hdd: request sense failure: error=0x00
Nov 10 23:05:21 unit0 kernel: hdd: status error: status=0x58 {
DriveReady SeekComplete DataRequest }
Nov 10 23:05:21 unit0 kernel: hdd: status error: error=0x00
Nov 10 23:05:21 unit0 kernel: hdd: drive not ready for command

My magicdev is configured to only run an application in the case of a
music cd is inseted. So I imagine that it could be an attempt to mount
the CD, by the add-remove program, while the magicdev is checking what
kind of CD is it, or vice-versa.  

Version-Release number of selected component (if applicable):
magicdev-1.1.4-7

How reproducible:
Always

Steps to Reproduce:
1. start add/remove program (redhat-config-packages)
2. select some pakage to be installed. 
3. insert the requested CD. 


    

Actual Results:  add-remove program says that there was an error in
the install and magicdev gets into 'D' state.

Expected Results:  The package selected get's installed.

Additional info:
Comment 1 Bevan Bennett 2004-01-27 21:15:07 EST
Created attachment 97291 [details]
Similar logs - without magicdev

Just in case it's helpful (I'm searching for bugs related to a problem I'm
seeing) I see similar log messages on a system that doesn't even have magicdev
installed (attached).

It's an IBM x330 server. I'll keep searching and probably end up posting my own
bug.
Comment 2 John (J5) Palmieri 2004-08-25 13:52:53 EDT
Closing.  Magicdev has been removed in favor of gnome-volume-manager
in devel branch.


Note You need to log in before you can comment on or make changes to this bug.