Bug 109707 - I have a Trident 3d cyberblade video card which is detected by video autoprobe as trident cyberblade (generic). This selection hangs my system. Old problem for me. Red Hat 8 offered panel during install to choose different videocard other than one auto...
I have a Trident 3d cyberblade video card which is detected by video autoprob...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 23:29 EST by warren burnett
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 14:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description warren burnett 2003-11-10 23:29:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)
Gecko/20020830

Description of problem:
I have a Trident 3d cyberblade video card which is detected by video
autoprobe during Fedora install as trident cyberblade (generic). This
selection hangs my system. Old problem for me. Red Hat 8 offered panel
during install to choose different videocard other than one
autoprobed. So I always choose Trident 3d cyberblade (generic) which
works great. Note the difference being the "3d". Can videocard
selection screen be included in Fedora install? It seems as though you
are just stuck with the probed value. I don't even make it through the
install. Many thanks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Do an install
2.
3.
    

Actual Results:  System hung after package installation step finished 

Expected Results:  Hoped for a working install of Fedora.

Additional info:
Comment 1 Jeremy Katz 2003-11-11 11:12:03 EST
Can you provide the output of lspci -v and lspci -vn?
Comment 2 warren burnett 2003-11-11 13:27:50 EST
Be glad to. Here it is:


%%%%%%%%%%%%%%%%%
lspci -v
%%%%%%%%%%%%%%%%%
00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia]
(rev 05)
        Flags: bus master, medium devsel, latency 8
        Memory at e0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
(prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: e4000000-e6ffffff
        Capabilities: [80] Power Management version 2

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super
South] (rev 
40)
        Subsystem: VIA Technologies, Inc. VT82C686/A PCI to ISA Bridge
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2

00:07.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus
Master IDE
(rev 06) (prog-if 8a [Master SecP PriP])
        Subsystem: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE
        Flags: bus master, medium devsel, latency 32
        I/O ports at d000 [size=16]
  Capabilities: [c0] Power Management version 2

00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 1a) (prog-if
00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at d400 [size=32]
        Capabilities: [80] Power Management version 2

00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 1a) (prog-if
00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at d800 [size=32]
        Capabilities: [80] Power Management version 2

00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
(rev 40)
        Subsystem: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
        Flags: medium devsel, IRQ 3
        Capabilities: [68] Power Management version 2

00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686
AC97 Audio
Controller (rev 50)
        Subsystem: VIA Technologies, Inc. VT82C686 AC97 Audio Controller
        Flags: medium devsel, IRQ 5
        I/O ports at dc00 [size=256]
 I/O ports at e000 [size=4]
        I/O ports at e400 [size=4]
        Capabilities: [c0] Power Management version 2

00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: Biostar Microtech Int'l Corp: Unknown device 00a3
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at ec00 [size=256]
        Memory at e8000000 (32-bit, non-prefetchable) [size=256]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [50] Power Management version 2

01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1
(rev 6a)
(prog-if 00 [VGA])
        Subsystem: Trident Microsystems CyberBlade/i1
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 10
        Memory at e5800000 (32-bit, non-prefetchable) [size=8M]
        Memory at e6000000 (32-bit, non-prefetchable) [size=128K]
        Memory at e5000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [80] AGP version 2.0
        Capabilities: [90] Power Management version 1
%%%%%%%%%%%%%%
lspci -vn
%%%%%%%%%%%%%%
00:00.0 Class 0600: 1106:0601 (rev 05)
        Flags: bus master, medium devsel, latency 8
        Memory at e0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 2.0

00:01.0 Class 0604: 1106:8601
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: e4000000-e6ffffff
        Capabilities: [80] Power Management version 2

00:07.0 Class 0601: 1106:0686 (rev 40)
        Subsystem: 1106:0000
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2

00:07.1 Class 0101: 1106:0571 (rev 06) (prog-if 8a [Master SecP PriP])
        Subsystem: 1106:0571
        Flags: bus master, medium devsel, latency 32
        I/O ports at d000 [size=16]
        Capabilities: [c0] Power Management version 2

00:07.2 Class 0c03: 1106:3038 (rev 1a)
        Subsystem: 0925:1234
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at d400 [size=32]
        Capabilities: [80] Power Management version 2

00:07.3 Class 0c03: 1106:3038 (rev 1a)
        Subsystem: 0925:1234
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at d800 [size=32]
        Capabilities: [80] Power Management version 2

00:07.4 Class 0680: 1106:3057 (rev 40)
        Subsystem: 1106:3057
        Flags: medium devsel, IRQ 3
        Capabilities: [68] Power Management version 2

00:07.5 Class 0401: 1106:3058 (rev 50)
        Subsystem: 1106:3058
        Flags: medium devsel, IRQ 5
        I/O ports at dc00 [size=256]
        I/O ports at e000 [size=4]
        I/O ports at e400 [size=4]
        Capabilities: [c0] Power Management version 2

00:0b.0 Class 0200: 10ec:8139 (rev 10)
        Subsystem: 1565:00a3
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at ec00 [size=256]
        Memory at e8000000 (32-bit, non-prefetchable) [size=256]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [50] Power Management version 2

01:00.0 Class 0300: 1023:8500 (rev 6a)
        Subsystem: 1023:8500
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 10
        Memory at e5800000 (32-bit, non-prefetchable) [size=8M]
        Memory at e6000000 (32-bit, non-prefetchable) [size=128K]
        Memory at e5000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [80] AGP version 2.0
        Capabilities: [90] Power Management version 1

Thanks
Warren
Comment 3 Jeremy Katz 2003-11-12 10:06:27 EST
So you used to select "Trident Blade3D (generic)"?  How do you have to
change your X configuration to get things working?
Comment 4 warren burnett 2003-11-12 14:57:01 EST
Just the driver selection during operating system install. During the 
Red Hat 8 installation there is a screen that highlights the video 
driver that autoprobe thinks is the right one and asks iif you wanty 
to change it. The highlighted one is Trident cyberblade (generic). 
I've done a large number of re-installs. Every time I let the 
installer use the default (cyberblade generic). I always get hard 
freezes when using X and I have to reboot to recover. Basically X is 
unusable. However, if, during install, I change the video selection 
from (cyberblade generic) to (3D cyberblade generic), then X behaves 
just great with no problems. I have a self-built pc with the video 
built in to the motherboard and it was described as 3D in the 
motherboard doc. 
The reason I put this problem in is that I wanted to re-install 
Fedora core 1 and junk Red Hat 8. The Fedora install screens do not 
give you the option to override the video selection. It just 
autoprobes, comes up with (cyberblade generic), and you are stuck 
with it. And by stuck I mean I don't even get much beyond package 
installation. The install starts asking for responses to questions 
and FREEZE. Hard Lock-up. Reboot.
Red Hat 8 install did have the screen that gave you the option to 
select a different video driver. If there's any way that could be put 
into the Fedora install, I'd be grateful.    
Comment 5 warren burnett 2008-08-02 16:16:37 EDT
The original summary for this bug was longer than 255 characters, and so it was truncated when Bugzilla was upgraded. The original summary was:

I have a Trident 3d cyberblade video card which is detected by video autoprobe as trident cyberblade (generic). This selection hangs my system. Old problem for me. Red Hat 8 offered panel during install to choose different videocard other than one autoprobed. So I always choose Trident 3d cyberblade (generic) which works great. Note the difference being the "3d". Can videocard selection screen be included in Fedora install? It seems as though you are just stuck with the probed value. I don't even make it through the install. Many thanks.

Note You need to log in before you can comment on or make changes to this bug.