This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 109713 - Update to bind 9.2.3 - contains various useful fixes
Update to bind 9.2.3 - contains various useful fixes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
1
All Linux
high Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 02:39 EST by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: bind-9.2.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-13 12:14:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2003-11-11 02:39:30 EST
Description of problem:
Since October 23, 2003 bind 9.2.3 is released, contains various useful fixes...see the CHANGES file for more information.

I know, there are a lof fixes by Red Hat...but I can't believe, that all problems from bind 9.2.3 are solved by the Red Hat patches...

Version-Release number of selected component (if applicable):
bind-9.2.3-P3-9

Additional info:
Rebuilding without re-enable of the existing patches seems to work. May there are to add new patches.
Comment 1 Daniel Walsh 2003-11-11 11:06:05 EST
I have made the bind-9.2.3-1 version of the RPM.  It should be
available in rawhide soon.   It will be in FC2
Comment 2 Robert Scheck 2003-11-12 04:24:30 EST
I still can't use the rebuilded RPM (rebuild was successfull), but look, please:

# rpm -Uvh bind-9.2.3-1.i386.rpm bind-devel-9.2.3-1.i386.rpm bind-utils-9.2.3-1.i386.rpm
Error: Failed dependencies:
        libdns.so.10 is needed by bind-9.2.3-1
        libisc.so.4 is needed by bind-9.2.3-1
        libisc.so.4 is needed by bind-utils-9.2.3-1
#

# less bind-utils-9.2.3-1.i386.rpm
[...]
lrwxrwxrwx    1 root    root               16 Nov 12 09:15 /usr/lib/libdns.so.11 -> libdns.so.11.0.2
-rwxr-xr-x    1 root    root          2606123 Nov 12 09:15 /usr/lib/libdns.so.11.0.2
lrwxrwxrwx    1 root    root               15 Nov 12 09:15 /usr/lib/libisc.so.7 -> libisc.so.7.0.1
-rwxr-xr-x    1 root    root           771249 Nov 12 09:15 /usr/lib/libisc.so.7.0.1
[...]

I can't see the problem...why is there eg. a dependencie from bind-utils-9.2.3-1 to libisc.so.4 while libisc.so.7 is provided?

Any idea what maybe is wrong would be very helpful... ;-)
Comment 3 Robert Scheck 2003-11-12 09:44:54 EST
Okay, I think, I know the problem:

If I remove %clean from the spec file, rebuild a binary rpm, go to the build directory, do a make (and make install) and after that rebuild the rpm again, all works fine. But that solution is in my opinion still wrong and very ugly!

Looking at the code there are about 15 paths the start with / for the includes.

Please fix those problems through patches.

Only then there will be a correct binary bind RPM.
Comment 4 Daniel Walsh 2003-11-12 22:30:17 EST
I have made the bind-9.2.3-2 version of the RPM.  It should be
available in rawhide soon.   It will be in FC2

Hopefully this one will work.

Dan
Comment 5 Robert Scheck 2003-11-13 12:14:58 EST
Yepp, now it works fine :-)

Thank you.

Note You need to log in before you can comment on or make changes to this bug.