Bug 109714 - USB printer HP 845c does not print at all
USB printer HP 845c does not print at all
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 03:31 EST by Laszlo Bathory
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 7.07-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-11 08:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laszlo Bathory 2003-11-11 03:31:38 EST
Description of problem:
USB printer is up, cups is running, every print command yields, 
only "Media tray empty" message appears eg. in cups web interface. 
(this is not the problem itself)

Version-Release number of selected component (if applicable):


How reproducible:
install hp845c with cups or printconf.gui, try to print test page or 
anything 

Steps to Reproduce:
1. install printer
2. try to print test page or lpr test.txt etc
3.
  
Actual results:
nothing happens

Expected results:
print the page

Additional info:
It happens with FC's kernel and with the official 2.4.22 as well.

D [10/Nov/2003:19:58:21 +0100] StartJob(8, 0x80a31a0)
D [10/Nov/2003:19:58:21 +0100] StartJob() id = 8, file = 0/1
D [10/Nov/2003:19:58:21 +0100] job-sheets=none,none
D [10/Nov/2003:19:58:21 +0100] banner_page = 0
D [10/Nov/2003:19:58:21 +0100] StartJob: argv 
= "HPDeskjet","8","","Test Page","1","","/var/spool/cups/d00008-001"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[0]
="PATH=/usr/lib/cups/filter:/bin:/usr/bin"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[1]="SOFTWARE=CUPS/1.1"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[2]="USER=root"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[3]="CHARSET=iso-8859-1"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[4]="LANG=c-"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[5]=""
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[6]
="PPD=/etc/cups/ppd/HPDeskjet.ppd"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[7]
="CUPS_SERVERROOT=/etc/cups"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[8]="RIP_MAX_CACHE=8m"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[9]
="TMPDIR=/var/spool/cups/tmp"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[10]
="CONTENT_TYPE=application/postscript"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[11]
="DEVICE_URI=usb:/dev/usb/lp0"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[12]="PRINTER=HPDeskjet"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[13]
="CUPS_DATADIR=/usr/share/cups"
D [10/Nov/2003:19:58:21 +0100] StartJob: envp[14]
="CUPS_FONTPATH=/usr/share/cups/fonts"
D [10/Nov/2003:19:58:21 +0100] StartJob: statusfds = [ 11 12 ]
D [10/Nov/2003:19:58:21 +0100] StartJob: filterfds[1] = [ 13 -1 ]
D [10/Nov/2003:19:58:21 +0100] StartJob: filter 
= "/usr/lib/cups/filter/pstops"
D [10/Nov/2003:19:58:21 +0100] StartJob: filterfds[0] = [ 14 15 ]
D [10/Nov/2003:19:58:21 +0100] start_process
("/usr/lib/cups/filter/pstops", 0xbfff0210, 0xbffef580, 13, 15, 12)
I [10/Nov/2003:19:58:21 +0100] Started 
filter /usr/lib/cups/filter/pstops (PID 7527) for job 8.
D [10/Nov/2003:19:58:21 +0100] StartJob: filter 
= "/usr/lib/cups/filter/foomatic-rip"
D [10/Nov/2003:19:58:21 +0100] StartJob: filterfds[1] = [ 13 16 ]
D [10/Nov/2003:19:58:21 +0100] start_process
("/usr/lib/cups/filter/foomatic-rip", 0xbfff0210, 0xbffef580, 14, 16, 
12)
I [10/Nov/2003:19:58:21 +0100] Started 
filter /usr/lib/cups/filter/foomatic-rip (PID 7528) for job 8.
D [10/Nov/2003:19:58:21 +0100] StartJob: backend 
= "/usr/lib/cups/backend/usb"
D [10/Nov/2003:19:58:21 +0100] StartJob: filterfds[0] = [ -1 14 ]
D [10/Nov/2003:19:58:21 +0100] start_process
("/usr/lib/cups/backend/usb", 0xbfff0210, 0xbffef580, 13, 14, 12)
I [10/Nov/2003:19:58:21 +0100] Started 
backend /usr/lib/cups/backend/usb (PID 7529) for job 8.
D [10/Nov/2003:19:58:21 +0100] ProcessIPPRequest: 8 status_code=0
D [10/Nov/2003:19:58:21 +0100] AcceptClient() 12 from localhost:631.
D [10/Nov/2003:19:58:21 +0100] ReadClient() 12 POST / HTTP/1.1
D [10/Nov/2003:19:58:21 +0100] ProcessIPPRequest: 12 status_code=1
D [10/Nov/2003:19:58:21 +0100] [Job 8] perl: warning: Setting locale 
failed.
D [10/Nov/2003:19:58:21 +0100] [Job 8] perl: warning: Please check 
that your locale settings:
D [10/Nov/2003:19:58:21 +0100] [Job 8] LANGUAGE = (unset),
D [10/Nov/2003:19:58:21 +0100] [Job 8] LC_ALL = (unset),
D [10/Nov/2003:19:58:21 +0100] [Job 8] LANG = "c-"
D [10/Nov/2003:19:58:21 +0100] [Job 8] are supported and installed on 
your system.
D [10/Nov/2003:19:58:21 +0100] [Job 8] perl: warning: Falling back to 
the standard locale ("C").
D [10/Nov/2003:19:58:21 +0100] CloseClient() 8
D [10/Nov/2003:19:58:21 +0100] [Job 8] LPGETSTATUS returned a port 
status of 18...
W [10/Nov/2003:19:58:21 +0100] [Job 8] Media tray empty!
D [10/Nov/2003:19:58:21 +0100] [Job 8] Page = 595x842; 10,36 to 
585,833
D [10/Nov/2003:19:58:21 +0100] [Job 8] slowcollate=0, slowduplex=0, 
sloworder=0
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%BoundingBox: 0 0 612 792
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%Pages: 1
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%LanguageLevel: 1
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%DocumentData: Clean7Bit
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%DocumentSuppliedResources: 
procset testprint/1.0
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%DocumentNeededResources: 
font Helvetica Helvetica-Bold Times-Roman
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%Creator: Michael Sweet, 
Easy Software Products
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%CreationDate: May 11, 1999
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%Title: Test Page
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%EndComments
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%BeginProlog
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%BeginResource procset 
testprint 1.1 0
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%EndResource
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%EndProlog
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%Page: 1 1
D [10/Nov/2003:19:58:21 +0100] [Job 8] 0 %%Page: 1 1
D [10/Nov/2003:19:58:21 +0100] [Job 8] pw = 575.6, pl = 797.0
D [10/Nov/2003:19:58:21 +0100] [Job 8] PageLeft = 9.7, PageRight = 
585.3
D [10/Nov/2003:19:58:21 +0100] [Job 8] PageTop = 833.0, PageBottom = 
36.0
D [10/Nov/2003:19:58:21 +0100] [Job 8] PageWidth = 595.0, PageLength 
= 842.0
D [10/Nov/2003:19:58:22 +0100] [Job 8] foomatic-rip version 
$Revision: 3.30 $ running...
D [10/Nov/2003:19:58:22 +0100] [Job 8] Parsing PPD file ...
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option ColorSpace
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option Resolution
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option PageSize
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option PageRegion
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option Model
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option PrintoutMode
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option ImageableArea
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option PaperDimension
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option Quality
D [10/Nov/2003:19:58:22 +0100] [Job 8] Added option Font
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] Parameter Summary
D [10/Nov/2003:19:58:22 +0100] [Job 8] -----------------
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] Spooler: cups
D [10/Nov/2003:19:58:22 +0100] [Job 8] Printer: HPDeskjet
D [10/Nov/2003:19:58:22 +0100] [Job 8] PPD 
file: /etc/cups/ppd/HPDeskjet.ppd
D [10/Nov/2003:19:58:22 +0100] [Job 8] Printer model: HP DeskJet 
845C, Foomatic + hpijs (recommended)
D [10/Nov/2003:19:58:22 +0100] [Job 8] Job title: Test Page
D [10/Nov/2003:19:58:22 +0100] [Job 8] File(s) to be printed:
D [10/Nov/2003:19:58:22 +0100] [Job 8] <STDIN>
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
================================================
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] File: <STDIN>
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
================================================
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] Reading PostScript input ...
D [10/Nov/2003:19:58:22 +0100] [Job 8] --> This document is DSC-
conforming!
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] -----------
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %%BeginProlog
D [10/Nov/2003:19:58:22 +0100] [Job 8] 0 %%EOF
D [10/Nov/2003:19:58:22 +0100] [Job 8] Saw EOF!
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %%EndProlog
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] -----------
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %%BeginSetup
D [10/Nov/2003:19:58:22 +0100] [Job 8] Inserting PostScript code for 
CUPS' page accounting
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %%BeginFeature: 
*PrintoutMode Normal
D [10/Nov/2003:19:58:22 +0100] [Job 8] Option: PrintoutMode=Normal --
> Setting option
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %% 
FoomaticRIPOptionSetting: PrintoutMode=Normal
D [10/Nov/2003:19:58:22 +0100] [Job 8] Option: PrintoutMode=Normal --
> Setting option
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %%BeginFeature: 
*Quality FromPrintoutMode
D [10/Nov/2003:19:58:22 +0100] [Job 8] Option: 
Quality=FromPrintoutMode --> Setting option
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %% 
FoomaticRIPOptionSetting: Quality=@PrintoutMode
D [10/Nov/2003:19:58:22 +0100] [Job 8] Option: 
Quality=FromPrintoutMode --> Setting option
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %%BeginFeature: 
*PageSize A4
D [10/Nov/2003:19:58:22 +0100] [Job 8] Option: PageSize=A4 --> 
Setting option
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %% 
FoomaticRIPOptionSetting: PageSize=A4
D [10/Nov/2003:19:58:22 +0100] [Job 8] Option: PageSize=A4 --> 
Setting option
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found: %%EndSetup
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] -----------
D [10/Nov/2003:19:58:22 +0100] [Job 8] New page:  1 1
D [10/Nov/2003:19:58:22 +0100] [Job 8] Inserting option code 
into "PageSetup" section.
D [10/Nov/2003:19:58:22 +0100] [Job 8] No page header or page header 
not DSC-conforming
D [10/Nov/2003:19:58:22 +0100] [Job 8] Stopping search for page 
header options
D [10/Nov/2003:19:58:22 +0100] [Job 8] Found:
D [10/Nov/2003:19:58:22 +0100] [Job 8] pageHeight sub		
	% Move down...
D [10/Nov/2003:19:58:22 +0100] [Job 8] --> Output goes directly to 
the renderer now.
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] Starting renderer
D [10/Nov/2003:19:58:22 +0100] [Job 8] renderer PID pid4=7531
D [10/Nov/2003:19:58:22 +0100] [Job 8] renderer command: gs -q -
dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -
sIjsServer=hpijs -sDeviceManufacturer="HEWLETT-PACKARD" -
sDeviceModel="DESKJET 845" -dDEVICEWIDTHPOINTS=595 -
dDEVICEHEIGHTPOINTS=842 -r300 -
sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Q
uality:PenSet=1 -dIjsUseOutputFD -sOutputFile=- -
D [10/Nov/2003:19:58:22 +0100] [Job 8] JCL: <job data>
D [10/Nov/2003:19:58:22 +0100] [Job 8] 
D [10/Nov/2003:19:58:22 +0100] [Job 8] perl: warning: Setting locale 
failed.
D [10/Nov/2003:19:58:22 +0100] [Job 8] perl: warning: Please check 
that your locale settings:
D [10/Nov/2003:19:58:22 +0100] [Job 8] LANGUAGE = (unset),
D [10/Nov/2003:19:58:22 +0100] [Job 8] LC_ALL = (unset),
D [10/Nov/2003:19:58:22 +0100] [Job 8] LANG = "c-"
D [10/Nov/2003:19:58:22 +0100] [Job 8] are supported and installed on 
your system.
D [10/Nov/2003:19:58:22 +0100] [Job 8] perl: warning: Falling back to 
the standard locale ("C").
D [10/Nov/2003:19:58:22 +0100] [Job 8] foomatic-gswrapper: gs '-
dBATCH' '-dPARANOIDSAFER' '-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs' '-
sIjsServer=hpijs' '-sDeviceManufacturer=HEWLETT-PACKARD' '-
sDeviceModel=DESKJET 845' '-dDEVICEWIDTHPOINTS=595' '-
dDEVICEHEIGHTPOINTS=842' '-r300' '-
sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Q
uality:PenSet=1' '-dIjsUseOutputFD' '-sOutputFile=| cat 
>&3' '/dev/fd/0' 3>&1 1>&2
D [10/Nov/2003:19:58:23 +0100] [Job 8] hpijs: context.cpp:427: 
apdk::DRIVER_ERROR apdk::PrintContext::SelectPrintMode
(apdk::QUALITY_MODE, apdk::MEDIATYPE, apdk::COLORMODE, int): 
Assertion `0' failed.
D [10/Nov/2003:19:58:23 +0100] [Job 8] **** Unable to open the 
initial device, quitting.
D [10/Nov/2003:19:58:23 +0100] [Job 8] renderer return value: 1
D [10/Nov/2003:19:58:23 +0100] [Job 8] renderer received signal: 1
D [10/Nov/2003:19:58:23 +0100] [Job 8] Process dieing with "Possible 
error on renderer command line or PostScript error. Check options.", 
exit stat: 3
D [10/Nov/2003:19:58:23 +0100] [Job 8] Possible error on renderer 
command line or PostScript error. Check options.
D [10/Nov/2003:19:58:23 +0100] [Job 8] Flushing FIFO.
D [10/Nov/2003:19:58:23 +0100] [Job 8] 
D [10/Nov/2003:19:58:23 +0100] [Job 8] Closing renderer
D [10/Nov/2003:19:58:23 +0100] [Job 8] tail process done writing data 
to STDOUT
D [10/Nov/2003:19:58:23 +0100] [Job 8] KID4 finished
D [10/Nov/2003:19:58:23 +0100] [Job 8] KID3 exited with status 3
D [10/Nov/2003:19:58:23 +0100] [Job 8] Renderer exit stat: 3
E [10/Nov/2003:19:58:23 +0100] PID 7528 stopped with status 3!
D [10/Nov/2003:19:58:23 +0100] [Job 8] Renderer process finished
D [10/Nov/2003:19:58:23 +0100] [Job 8] Process dieing with "Error 
closing renderer", exit stat: 3
D [10/Nov/2003:19:58:23 +0100] [Job 8] Error closing renderer
D [10/Nov/2003:19:58:23 +0100] UpdateJob: job 8, file 0 is complete.
D [10/Nov/2003:19:58:23 +0100] CancelJob: id = 8
D [10/Nov/2003:19:58:23 +0100] StopJob: id = 8, force = 0
D [10/Nov/2003:19:58:23 +0100] StopJob: printer state is 3
Comment 1 Tim Waugh 2003-11-11 05:19:56 EST
Here are the important lines from the log (thanks!):

hpijs: context.cpp:427: 
apdk::DRIVER_ERROR apdk::PrintContext::SelectPrintMode
(apdk::QUALITY_MODE, apdk::MEDIATYPE, apdk::COLORMODE, int): 
Assertion `0' failed.
D [10/Nov/2003:19:58:23 +0100] [Job 8] **** Unable to open the 
initial device, quitting.
Comment 2 Tim Waugh 2003-11-11 08:37:55 EST
This seems to be fixed in hpijs-1.5, which will appear in rawhide
(fedora/development) soon.

Note You need to log in before you can comment on or make changes to this bug.