Bug 109725 - Can't unmount CD's using kernel 2.6-test9.1.78 from Arjanv
Can't unmount CD's using kernel 2.6-test9.1.78 from Arjanv
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 09:07 EST by Jacob Kroon
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 18:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Kroon 2003-11-11 09:07:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
If I try to umount a CD Nautilus tells me:

umount: /mnt/cdrom: device is busy

Some /sbin/fuser output:

                     USER        PID ACCESS COMMAND
/mnt/cdrom/          root     kernel mount  /mnt/cdrom

If I log out of X and back in, I can umount it.

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test9.1.78

How reproducible:
Always

Steps to Reproduce:
1. Right click on desktop and mount CD
2. Read something from the CD in nautilus.
3. Close nautilus and try to umount the CD
    

Actual Results:  Can't umount the CD, device busy

Expected Results:  CD should pop out of my drive

Additional info:
Comment 1 Arjan van de Ven 2003-11-11 09:08:23 EST
what does lsof show ?
Comment 2 Jacob Kroon 2003-11-11 09:18:32 EST
"lsof" gives nothing, it can't find any open files on the CD or if
/mnt/cdrom is open.
Comment 3 Jacob Kroon 2003-11-11 09:21:31 EST
Also, I had to remove "hdc=ide-scsi" from the kernel parameters in
order to access the CD at all. But maybe that's ok since ide-scsi is
deprecated in 2.6 (?).
Comment 4 Miloslav Trmac 2003-11-11 12:48:20 EST
This looks like a duplicate of bug 109687.
Comment 5 Jacob Kroon 2003-11-12 12:55:20 EST
I only experience this when running a 2.6-test* kernel, but it seems
odd no one else has reported this, since it's easy discovered.
Comment 6 Jacob Kroon 2003-11-13 07:03:26 EST
I've re-installed FC1, added Arjanv's 2.6.0-0.test9.1.83 kernel, and
it seems the problem has "gone away". I can't reproduce it anymore.
Comment 7 Jacob Kroon 2003-11-21 04:15:16 EST
The bug is back again. :( Using the same configuration as before. Also
I noticed that Nautilus eats 10MB of memory usage whenever I
succesfully or unsuccessfully unmount a CD in the "Disks" dialog. I've
notified the Nautilus developers about the issue.
Comment 8 Dave Jones 2004-06-18 19:24:39 EDT
did this go away with the fc2 kernel ?
Comment 9 Jacob Kroon 2004-07-05 12:33:02 EDT
Yes, everything is working fine in FC2.

Note You need to log in before you can comment on or make changes to this bug.