Bug 109729 - Neither base nor devel packages contain libstartup-notification-1.la
Neither base nor devel packages contain libstartup-notification-1.la
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: startup-notification (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 10:00 EST by Sergey V. Udaltsov
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 01:46:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey V. Udaltsov 2003-11-11 10:00:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Trying to build anything with startup-notification, getting the error
- because the shlib descriptor (.la file) is missing

Version-Release number of selected component (if applicable):
0.1

How reproducible:
Always

Steps to Reproduce:
Install libstartup-notification*, look in /usr/lib
    

Additional info:
Comment 1 Mark McLoughlin 2004-09-23 12:06:38 EDT
I can't give you the exact rationale, because I'm not sure precisely
what it is - something along the lines of "they're not neccessary on
Linux and cause more trouble than anything" - but we quite
deliberately don't ship the .la files with new libraries.

This shouldn't cause any issues - so you're going to need to explain
exactly what the problem you're seeing is.

(And apologies the bug has gone unattended so long)
Comment 2 Sergey V. Udaltsov 2004-09-23 15:07:06 EDT
Well, many things changed since that time:) IIRC at some point some
pkgconfig file contained the reference to that .la file - but it seems
now it is ok. So feel free to close the bug - if it happens again,
I'll reopen it:)

Note You need to log in before you can comment on or make changes to this bug.