Bug 109765 - kernel errors kill install
kernel errors kill install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 12:30 EST by Joe Harrington
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-14 16:05:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 2003-11-11 12:30:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
During install of Fedora Core 1, Fedora Core test3, Red Hat 9, and
Debian 3.0r1, the install fails at a random point, generally during
the non-interactive package loading phase.


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2115.nptl 

How reproducible:
Always

Steps to Reproduce:
1. install any Linux distro, or copy a large file on a live-CD distro
2.
3.
    

Actual Results:  System crashes.  VC messages indicate problems in
different programs each time.  Generally the failure happens during
package installation, but sometimes it happens earlier.  After the
first indication of a problem, one can generally still switch VCs, but
eventually that stops working, too.  Frequently, there are several
programs indicating problems in the VC screens.

Expected Results:  System does not crash.

Additional info:

I have never gotten the install to run to completion on this machine.
 It ran without trouble on an older machine (PPro 200) from the same
media.

The hardware:

Asus A7V600 mobo (VIA KT600 chipset)
AMD 2800+XP CPU
1536 MB DDR333 (3 sticks)
IDE disks (250GB WD)
IDE CD/DVD reader

On Morphix 0.4-1 (a live-CD linux distro), this configuration boots,
but crashes during large file copies (1GB or larger generally does it,
but it can happen much sooner than that, or occasionally take longer).

Things I have tried:
noapic nolapic acpi=off pci=noacpi allowcddma nodma
in various combinations and individually.  None worked.

I have tested and replaced the hardware extensively over the past
several months of chasing this problem down.  It is not hardware.  I
suspect it is a problem with chipset support in the kernel.  However,
I have not been able to find a reliable source of information about
the support status of various chipsets and motherboard features.
I had similar problems with an nVidia nForce2 mobo from Giga-Byte
using the distros above (except Fedora 1 and test3).  I no longer have
that board.

I have marked this bug as high priority because I (and I suspect
anyone else with a late-model motherboard) cannot get any flavor of
Linux to install.  Numerous researchers in my department (e.g., the
entire Mars Rover project) are switching to Macs from Linux because of
this and similar problems.  I don't see much of a reaction from kernel
developers, even to the extent of admitting a systematic problem and
providing info on what new hardware does work so we can purchase it
and move on.

--jh--
Comment 1 Joe Harrington 2003-11-11 14:05:24 EST
This is the same problem I reported in bug 108973 for the test3 release.

--jh--
Comment 2 Joe Harrington 2003-11-14 16:05:03 EST
This has turned out to be a problem with faulty memory.  All 4 sticks
of SimpleTech memory tested as good under memtest86, but the system
was unstable.  A stick of Corsair memory works well.  Memory and
motherboard manufacturers are now pointing the finger at each other. 
Anyway, the software (non-)issue is resolved.

--jh--

Note You need to log in before you can comment on or make changes to this bug.