Bug 109768 - floating point exception on startup of binary built on previous version of kernel
Summary: floating point exception on startup of binary built on previous version of ke...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
: 109770 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-11 17:38 UTC by Jared Harper
Modified: 2016-11-24 15:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 14:20:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file of crash (825.72 KB, application/octet-stream)
2003-11-15 02:44 UTC, Jared Harper
no flags Details

Description Jared Harper 2003-11-11 17:38:01 UTC
Description of problem:
ld-2.3.2.so crashes with a divide by zero FPE during startup.  My 
call stack is

allocate_static_tls()
_dl_relocate_object_internal()
dl_main()
_dl_sysdep_start()
_dl_start()


If I set LD_ASSUME_KERNEL=2.4.19 then the binary will run without the 
FPE.  This same binary will run on RH AS 2.1 (if I copy some 
libraries versions that are missing), RH 8, SuSE 8, 8.2.  I have not 
been able to try AS 3.0 yet.

NOTE: I have another application, built exactly the same, and that 
application will run without the FPE.  I can send a core file if that 
helps.  Since I never enter my application, I have not been able to 
get very far in debugging this.

Version-Release number of selected component (if applicable):
glibc-2.3.2
ld-2.3.2

How reproducible:

Steps to Reproduce:
1.gwmta -show
2.
3.
  
Actual results:
Floating point exception

Expected results:
Application should start and display a splash screen, then exit

Additional info:

Comment 1 Jakub Jelinek 2003-11-11 17:40:17 UTC
Please try ftp://people.redhat.com/jakub/glibc/errata/2.3.2-27.9.4/

Comment 2 Jared Harper 2003-11-11 18:02:54 UTC
I have just finished updating to 2.3.2-27.9 and the problem still 
exists.  I there something in 2.3.2-27.4 that is not in 27.9 that is 
worth back rev'ing.

Comment 3 Jakub Jelinek 2003-11-11 18:05:01 UTC
It is not 27.4 but 27.9.4 and there are several bugfixes for TLS
handling.  This is a RHL9 errata candidate.

Comment 4 Jared Harper 2003-11-11 18:32:15 UTC
No change in behavior with the 27.9.4

Comment 5 Jared Harper 2003-11-15 02:44:36 UTC
Created attachment 95990 [details]
core file of crash

Comment 6 Jakub Jelinek 2004-10-07 10:59:48 UTC
Are you still able to reproduce this with Fedora Core 3 test2
glibc?  If yes, please provide a self-contained testcase.

Comment 7 Jakub Jelinek 2004-10-07 11:00:24 UTC
*** Bug 109770 has been marked as a duplicate of this bug. ***

Comment 8 Jakub Jelinek 2004-11-11 14:20:26 UTC
Without a testcase there is nothing to do.


Note You need to log in before you can comment on or make changes to this bug.