Bug 109788 - rhnpush tracebacks
Summary: rhnpush tracebacks
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-11 20:01 UTC by Tom "spot" Callaway
Modified: 2007-07-31 19:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 18:52:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom "spot" Callaway 2003-11-11 20:01:12 UTC
Description of problem:

Traceback (innermost last):
  File "/usr/bin/rhnpush", line 13, in ?
    sys.exit(rhnpush.main(sys.argv) or 0)
  File "/var/www/rhns/rhnpush/rhnpush.py", line 96, in main
    upload.packages()
  File "/var/www/rhns/rhnpush/rhnpush.py", line 145, in packages
    ret = self.package(p)
  File "/var/www/rhns/rhnpush/rhnpush.py", line 193, in package
    self.username, self.password, hash)
  File "/var/www/rhns/rhnpush/uploadLib.py", line 510, in call
    ret = apply(function, params)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 689, in
__call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 746, in
__request
    self.__protocol
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 652, in
request
    return self.parse_response(fd)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 667, in
parse_response
    return u.close()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 364, in close
    raise ResponseError()
xmlrpclib.ResponseError: <xmlrpclib.ResponseError instance at 81c1f90>

This came as a result of the following command:

rhnpush --dir=/fs0/iso/disc1/RedHat/RPMS/
--channel=aurora-sparc-linux-1.0 --server=https://aun.anthonymendoza.com

[root@rhn RPMS]# rhnpush --dir=/fs0/iso/disc1/RedHat/RPMS/
--channel=aurora-sparc-linux-1.0 --server=https://rhn.anthonymendoza.com
Uploading files from directory /fs0/iso/disc1/RedHat/RPMS/
Red Hat Network username: spotrh
Red Hat Network password:
Connecting to https://rhn.anthonymendoza.com
Uploading package /fs0/iso/disc1/RedHat/RPMS/4Suite-0.11.1-8.sparc.rpm
Then, it tracebacks.

Version-Release number of selected component (if applicable):

rhnpush-2.6.1-4

Comment 1 Mihai Ibanescu 2003-11-11 20:11:14 UTC
Server URL should look like: http://your.hostname.com/APP

Comment 2 Tom "spot" Callaway 2004-09-28 18:52:10 UTC
Closing, because Aurora is no longer using the RHN Satellite.


Note You need to log in before you can comment on or make changes to this bug.