Bug 10980 - Install script in the RPM doesn't create a user correctly
Summary: Install script in the RPM doesn't create a user correctly
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-22 03:54 UTC by Dan Nungesser
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 16:34:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Nungesser 2000-04-22 03:54:32 UTC
The install script for postgresql that is supposed to add the postgres
user does not work with the adduser packaged in shadow-utils-19990827-10.
The for the flags is incorrect.  This causes the package to be installed
with all of the files owned by root, which is insecure and makes it
impossible to start when it is initialized as a service with "su -l
postgres" In order to fix it, I had to manually add the user using the
command:
    "useradd -u 26 -o -g postgres -d /var/lib/pgsql -s /bin/bash -
c "PostgreSQL Server" -M -r postgres"
It appears that this version of useradd requests that the uid be the first
argument.

and then install the packages.  Now it works like a charm.

Comment 1 Trond Eivind Glomsrxd 2000-04-24 16:34:59 UTC
I can't reproduce this - the same packages work here.


Note You need to log in before you can comment on or make changes to this bug.