Bug 109806 - Date time applet has sizing problems still
Summary: Date time applet has sizing problems still
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-11 23:46 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 2.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 15:53:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-panel-2.4.0-dateformatcy.patch (425 bytes, patch)
2004-02-24 16:54 UTC, Bart Martens
no flags Details | Diff

Description Alan Cox 2003-11-11 23:46:35 UTC
Description of problem:

Set the locale to cy_GB.UTF-8, stick a clock on your panel and wait
for the date size to change. The applet fails to resize so you end up
seeing

      Maw Tach 1

not

    Maw Tach 11

Now cy_GB is unusual for two reasons - the months are not 3 letters
long (this is not a bug - Ulrich says so) and the month lengths vary
for the short form.

Comment 1 Need Real Name 2003-11-12 04:25:31 UTC
It has similar problems if you drag it from a 48-pixel high panel to a
16-pixel (menu) high panel. Until you open the prefs and turn on/off
seconds or date you just get what _was_ on the first line in the
taller panel.

Comment 2 Bart Martens 2004-02-19 18:41:20 UTC
Alan, the problem is also reported upstream.
http://bugzilla.gnome.org/show_bug.cgi?id=122393


Comment 3 Leonard den Ottolander 2004-02-23 13:59:49 UTC
This seems to be a DUPLICATE of bug 79074.
Another upstream reference is
http://bugzilla.gnome.org/show_bug.cgi?id=97409


Comment 4 Leonard den Ottolander 2004-02-24 11:53:05 UTC
Alan, does an update to gnome-panel-2.4.2-1 fixes this issue?


Comment 5 Bart Martens 2004-02-24 16:54:14 UTC
Created attachment 97998 [details]
gnome-panel-2.4.0-dateformatcy.patch

This patch should fix the problem Alan reported. The fix is only for "cy". I
saw that a similar trick is already used for "li" and "nl".

Comment 6 Bart Martens 2004-02-24 17:27:35 UTC
I submitted a similar patch for "hu" upstream.
http://bugzilla.gnome.org/show_bug.cgi?id=122393


Comment 7 Mark McLoughlin 2004-03-02 15:53:16 UTC
Okay, a gnome-panel Fedora Core 1 Update (2.4.2-3) with a fix
for this bug is now available from:

   http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/

See the upstream bug (#112393) for more details


Note You need to log in before you can comment on or make changes to this bug.