Bug 109808 - bind-chroot fails under relocation
bind-chroot fails under relocation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 19:03 EST by ratness
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-29 07:41:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ratness 2003-11-11 19:03:14 EST
Description of problem:
Trying to relocate the location of the chroot jail fails, due to the 
default path being hardcoded into the scripts portion of the RPM.

I don't know if the RPM can pass the relocation into the script 
portions or not, but, it's not doing it.

Version-Release number of selected component (if applicable):
bind-chroot-9.2.2.P3-9

How reproducible:
Every Time.

Steps to Reproduce:
1. rpm -U --relocate=/var/named/chroot=/var/roots/named bind-9.2.2.P3-
9.i386.rpm bind-utils-9.2.2.P3-9.i386.rpm bind-chroot-9.2.2.P3-
9.i386.rpm 
  
Actual results:
warning: /etc/rndc.conf created as /etc/rndc.conf.rpmnew
warning: /etc/rndc.key created as /etc/rndc.key.rpmnew
mknod: `/var/named/chroot/dev/null': No such file or directory
chmod: failed to get attributes of `/var/named/chroot/dev/null': No 
such file or directory
mknod: `/var/named/chroot/dev/random': No such file or directory
chmod: failed to get attributes of `/var/named/chroot/dev/random': No 
such file or directory
chown: failed to get attributes of `/var/named/chroot/dev/random': No 
such file or directory
cp: cannot create regular file `/var/named/chroot/etc/localtime': No 
such file or directory
cp: cannot create regular file `/var/named/chroot/etc/rndc.key': No 
such file or directory
chown: failed to get attributes of `/var/named/chroot/etc/rndc.key': 
No such file or directory
chown: failed to get attributes of `/var/named/chroot/var/named': No 
such file or directory

Expected results:
Clean install and relocation of the chroot in /var/roots/named.

Additional info:
Comment 1 Daniel Walsh 2003-12-29 07:41:44 EST
This is not supported by RPM or RedHat.  You will have to do this by
hand.  Sorry.

Dan

Note You need to log in before you can comment on or make changes to this bug.