Bug 109857 - LTC5293-redhat-config-packages reports an improper message when removing packages
LTC5293-redhat-config-packages reports an improper message when removing pack...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-packages (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 10:03 EST by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-12 10:16:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-11-12 10:03:43 EST
The following has be reported by IBM LTC:  
redhat-config-packages reports an improper message when removing packages
Hardware Environment: iSeries 64bit

Software Environment: RHEL 3 GA


Steps to Reproduce:
1. Run the redhat-config-packages application
2. Attempt to remove a package group like 'Office/Productivity'
3. Select 'Update'

Actual Results:
An error window pops up stating: 

  Package Not Found
  The following package could not be found on your system.
  Installation cannot continue until it is installed.

  Unlocatable Package      Required By
  kdepim                   (kdenetwork', '3.1.3', '1.5')

Expected Results:
The message above is confusing because the package actually is
installed.  
kdepim is one of the packages that I am trying to remove.  It can't be
removed 
because the kdenetwork package requires it.  The error message, however, 
suggests that the package can't be removed because it isn't installed.

The message it would be more accurate if it reported a dependency
problem and 
explained that the package below is required by the package indicated.

Additional Information:Glen / Greg / Mark,
Talked to Mike Ranweiler, please report problem to RedHat.  ThanksI
ever run into a similar problem on pSeries, following is my comment on
BZ# 
4475: 

------- Additional Comment #6 From Wu Zhou 2003-09-28 21:32 ------- 
The redhat-config-packages in RC1 is updated to 1.2.5-1. No traceback
while 
deleting kdegraphics package, or any other packages which have
dependency on 
others. However the "Package Not Found" window still pop out. Although
this is 
insignificant, this message is somewhat misleading. Could this message
change 
to "Failed Dependency" or any others? Thanks!

Since that we don't receive any response.
Comment 1 IBM Bug Proxy 2003-11-12 10:14:26 EST
------ Additional Comments From gjlynx@us.ibm.com(prefers email via gjohnson@austin.ibm.com)  2003-12-11 10:11 -------
subject--:Subject: [Bug 109857] New: LTC5293-redhat-config-packages reports an improper message when removing packages 
Comment 2 Jeremy Katz 2003-11-12 10:16:27 EST
Changing strings at this point breaks translations and so can't really
be done.
Comment 3 mark wisner 2003-11-24 22:38:25 EST
------ Additional Comments From khoa@us.ibm.com  2003-24-11 22:10 -------
Red Hat has deferred this bug, so I'd like to do the same here. 
Comment 4 IBM Bug Proxy 2004-04-13 19:58:00 EDT
----- Additional Comments From pbowen@us.ibm.com  2004-04-13 20:00 -------
Mike R - should we open this for RHEL 4? 
Comment 5 IBM Bug Proxy 2004-11-09 11:41:10 EST
----- Additional Comments From pbowen@us.ibm.com  2004-11-09 11:41 EDT -------
Same with this bug; try on RHEL4, should be easy to check. Close or comment. 
Comment 6 IBM Bug Proxy 2004-11-29 11:29:22 EST
----- Additional Comments From yongwenw@us.ibm.com  2004-11-29 11:22 EDT -------
I have tried this on RHEL4 Beta2, I installed all extra packages in 
office/productivity. Then tried to remove the group and update. I got the 
following error

Package Not Found
  The following package could not be found on your system.
  Installation cannot continue until it is installed.

  Unlocatable Package      Required By
  openoffice.org           (openoffice.org-libs', '1.1.2', '10')

openoffice.org is actually installed on the system. so I think the bug hasn't 
been fixed yet. 
Comment 7 IBM Bug Proxy 2005-06-13 00:23:11 EDT
---- Additional Comments From khoa@us.ibm.com  2005-06-13 00:19 EDT -------
There should be another bug report for RHEL4.  This bug report should
be for RHEL3 family only.  If there is no  bug report for RHEL4, please
open one.  Thanks. 
Comment 8 IBM Bug Proxy 2005-06-20 15:25:33 EDT
---- Additional Comments From yongwenw@us.ibm.com  2005-06-20 15:21 EDT -------
Since this bug is now in Rejected and will not fix, should I close it? 
Comment 9 IBM Bug Proxy 2005-06-20 16:00:19 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
          QAContact|khoa@us.ibm.com             |mranweil@us.ibm.com




------- Additional Comments From mranweil@us.ibm.com  2005-06-20 15:56 EDT -------
Please.  My understanding is that config-packages will be different in rhel5.... 

Note You need to log in before you can comment on or make changes to this bug.