Bug 1098863 - Login from the email verification page attempts to direct to nonexistent /account url
Summary: Login from the email verification page attempts to direct to nonexistent /acc...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Authentication-Kerberos
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Damian Jansen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-19 04:56 UTC by David Mason
Modified: 2015-07-29 03:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 03:25:05 UTC


Attachments (Terms of Use)

Description David Mason 2014-05-19 04:56:44 UTC
Description of problem:
After email verification on a server using kerberos authentication, signing in from the email verification confirmation page causes the user to be directed to an invalid URL:

<zanata server>/account/%2F


Version-Release number of selected component (if applicable):
Zanata 3.4.0-SNAPSHOT (git-server-3.3.2-345-gaa6d307)

How reproducible:


Steps to Reproduce:
1. Sign in with a valid kerberos ID that has not yet been used on the server
2. Fill in name, username and a valid email address
3. Open the verification email and open the activation link
4. Sign in using kerberos username and password

Actual results:
User is directed to /account//

Expected results:
User is directed to a valid URL

Comment 1 Ding-Yi Chen 2014-05-20 02:16:02 UTC
I cannot reproduce it with Zanata 3.4.0-SNAPSHOT (git-server-3.3.2-351-gdebfc4e), would you mind test it again?

Comment 2 David Mason 2014-05-20 02:56:21 UTC
This appears only to occur in Firefox 17.0.7
Does not occur on:
 - Chrome 24.0.1312.69
 - Chrome 34.0.1847.137
 - Firefox 24.5

Comment 3 David Mason 2014-05-20 02:58:33 UTC
The bug still occurs in Zanata 3.4.0-SNAPSHOT (git-server-3.3.2-351-gdebfc4e), but I can only reproduce it in an older version of firefox.

Comment 4 Zanata Migrator 2015-07-29 03:25:05 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-251


Note You need to log in before you can comment on or make changes to this bug.