Bug 109908 - Nimbus Sans is only displayed condensed in AbiWord
Summary: Nimbus Sans is only displayed condensed in AbiWord
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-12 20:30 UTC by J. J. Ramsey
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 11:23:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pic from FC3 (3.04 KB, image/png)
2004-07-29 11:21 UTC, Caolan McNamara
no flags Details

Description J. J. Ramsey 2003-11-12 20:30:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Abiword can only seem to display the condensed (scrunched together)
version of Nimbus Sans L, even though both the regular and condensed
versions of the font are installed. Abiword doesn't even seem to see
that there are both regular and condensed versions of the font.


Version-Release number of selected component (if applicable):
abiword-2.0.1-1

How reproducible:
Always

Additional info:

If I use the GNOME fonts preferences panel to see what forms of the
Nimbus Sans L are available, both the regular and condensed forms are
*listed*, but condensed displays the same as regular. xfontsel only
shows the regular version of the font. When viewing the directory
/usr/share/fonts/default/Type1 with Nautilus, however, it is apparent
that both regular and condensed versions of the font are installed;
compare the previews of the files n0190031.pfb and n0190431.pfb, or
n0190041.pfb and n0190441.pfb.

Comment 1 Michael Elkins 2004-05-21 21:59:00 UTC
I also see this problem with Mozilla 1.6 on Fedora Core 2.  I suspect
that freetype or fontconfig is the culprit here.  When I visit a web
page with font-family: helvetica, fontconfig will substitute Nimbus
Sans L in place.  At smaller font sizes, the condensed font really
looks bad because some of the letters butt up against their neighbors.
 I made a screenshot to show this behavior:
http://www.cs.hmc.edu/~me/moz.png


Comment 2 Caolan McNamara 2004-07-29 11:21:48 UTC
Created attachment 102280 [details]
pic from FC3

Seems good to me in FC3, condensed is available seperate from normal and
appears as expected

Comment 3 Caolan McNamara 2004-07-29 11:23:39 UTC
Closing


Note You need to log in before you can comment on or make changes to this bug.