Bug 109923 - Rebuild with build_libgs generates libstdc++.so.4 dependency
Rebuild with build_libgs generates libstdc++.so.4 dependency
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 19:21 EST by Persio Barros
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-13 05:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Persio Barros 2003-11-12 19:21:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Tried to rebuild the source rpm after editing the spec file in order
to get the shared library libgs.so included in the binary package. The
compilation completes but the resulting rpm file reports dependency on
libstdc++.so.4, which is not intalled, nor is provided by any package
I could find. The library present is libstdc++.so.5.
The command "ldd BUILD/ghostscript-7.07/sobin/libgs.so" also shows the
dependency on the libstdc++.so.4 library.

Version-Release number of selected component (if applicable):
ghostscript-7.07-11

How reproducible:
Always

Steps to Reproduce:
1.Install the src rpm file
2.Edit SPECS/ghostcript.spec, seting build_libgs
3.Run rpmbuild -bb ghostscript.spec
4.Try to install the binary rpm file.
    

Actual Results:  The rpm command returns the error:
error: Failed dependencies:
        libstdc++.so.4 is needed by ghostscript-7.07-11

Expected Results:  No error

Additional info:
Comment 1 Tim Waugh 2003-11-13 05:05:50 EST
Works fine here.
Comment 2 Persio Barros 2003-11-13 05:35:05 EST
So...
What can be wrong here?
My system is: P4-1.8Ghz, 528Mb RAM, Fedora Core 1 freshly installed
(not upgraded).
Any clue?
Comment 3 Persio Barros 2003-11-13 06:01:41 EST
You can get a log of the rebuild process in:
http://www.fec.unicamp.br/~persio/rpmbuild.log.gz

Maybe this helps. Thanks
Comment 4 Persio Barros 2003-11-13 13:22:17 EST
Some more information:
I tried to recompile again the sorce rpm with build_gslib set to 1,
but this time in another system with RH9 and gcc 3.2.2-5. Now the
resulting binary rpm is OK. Strange...
Can this be due to the gcc compiler in Fedora?

Note You need to log in before you can comment on or make changes to this bug.