Bug 109939 - drawers open by themselves when panel unhides
drawers open by themselves when panel unhides
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 00:29 EST by David Carson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 10:54:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fixes hide on open drawer (2.95 KB, patch)
2004-02-19 05:07 EST, Leonard den Ottolander
no flags Details | Diff
Fixes auto open of drawer on unhide (3.10 KB, patch)
2004-02-19 05:07 EST, Leonard den Ottolander
no flags Details | Diff

  None (edit)
Description David Carson 2003-11-13 00:29:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When the gnome-panel unhides (either automatically or manually), all
the drawers open and remain open.  Moreover, if the panel is set to
autohide, an attempt to click on an icon in the drawer is impossible
because the panel disappears while attempting to position the mouse
and click.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-3

How reproducible:
Always

Steps to Reproduce:
1.Create a drawer and place a launcher in it.
2.Hide the panel (manually or via autohide).
3.Unhide the panel and the drawers will open.
4.In autohide mode, unhide the panel, put the mouse over the launcher
icon and observe that the panel hides itself again.
    

Actual Results:  The drawers open when they should not, and the panel
hides when it should not.

Expected Results:  The drawers should only open when explicitly opened.
The launcher icon in the drawer should remain visible when the user
attempts to click on it.

Additional info:
Comment 1 Bart Martens 2004-02-10 18:00:24 EST
Is already fixed upstream.

See http://bugzilla.gnome.org/show_bug.cgi?id=124794 and other
duplicate and re-scope bugs.
Comment 2 Leonard den Ottolander 2004-02-12 14:35:22 EST
Please reopen so the patch can be applied and taken through testing.
Comment 3 David Carson 2004-02-12 15:57:29 EST
This is being tracked by Gnome bug #121382.  I wanted to close this as
a duplicate, but that is a different bugzilla.  I will go ahead and
reopen it.
Comment 4 Leonard den Ottolander 2004-02-12 17:47:25 EST
Thanks. I was thinking of bundling some upstream patches and see if
they can go into testing.
Comment 5 Leonard den Ottolander 2004-02-19 05:07:03 EST
Created attachment 97829 [details]
Fixes hide on open drawer
Comment 6 Leonard den Ottolander 2004-02-19 05:07:43 EST
Created attachment 97830 [details]
Fixes auto open of drawer on unhide
Comment 7 Mark McLoughlin 2004-02-23 05:22:30 EST
Fix is in gnome-panel-2.4.2 so will be in the FC1 update I hope to
release this week.
Comment 8 Mark McLoughlin 2004-02-23 17:44:00 EST
I've just released a testing update which should fix this issue.
Please test it out and let us know if it fixes your problem.

Details on the update:
http://www.redhat.com/archives/fedora-test-list/2004-February/msg01512.html
Comment 9 Mark McLoughlin 2004-03-02 10:54:07 EST
Okay, a gnome-panel Fedora Core 1 Update (2.4.2-3) with a fix
for this bug is now available from:

   http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/

Note You need to log in before you can comment on or make changes to this bug.