Bug 109946 - Radeon drivers make all colors look white-washed and resolution goes down the tubes.
Radeon drivers make all colors look white-washed and resolution goes down the...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 04:57 EST by Gregory Harris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 12:50:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log (38.63 KB, text/plain)
2003-11-13 05:00 EST, Gregory Harris
no flags Details
Comments from the XFree86 mailing list (xfree86@xfree86.org) as to why Option "CrtScreen" has been removed from xfree86 (why it doesn't work with the gatos drivers) (7.34 KB, text/html)
2003-11-13 16:52 EST, Gregory Harris
no flags Details
XF86 Config file (3.32 KB, text/plain)
2003-11-13 17:17 EST, Gregory Harris
no flags Details

  None (edit)
Description Gregory Harris 2003-11-13 04:57:03 EST
Description of problem:

During and after installation the screen appears "white-washed".  Blue
appears baby-blue.  Red appears orangeish, and none of the fonts or
icons are smooth.  Some text is invisible.  Installing the gatos
driver (gatos.sf.net) makes the Xserver consistently think the monitor
is a flat panel, preventing X from starting and Option "CrtScreen" has
no effect.

Version-Release number of selected component (if applicable):
Xfree86 4.3.0 / Fedora Core 1

How reproducible:
Always

Steps to Reproduce:
1. Buy an AIW Radeon 7500 card and install in your machine.
2. Install Fedora (squinting to see the text) or in text mode
3. Enjoy a very poor display.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gregory Harris 2003-11-13 05:00:55 EST
Created attachment 95942 [details]
XFree86 log
Comment 2 Gregory Harris 2003-11-13 16:52:00 EST
Created attachment 95955 [details]
Comments from the XFree86 mailing list (xfree86@xfree86.org) as to why Option "CrtScreen" has been removed from xfree86 (why it doesn't work with the gatos drivers)


original html file located at:

http://www.mail-archive.com/xfree86@xfree86.org/msg03284.html
Comment 3 Gregory Harris 2003-11-13 17:17:14 EST
Created attachment 95958 [details]
XF86 Config file
Comment 4 Mike A. Harris 2003-11-13 17:33:32 EST
>During and after installation the screen appears "white-washed". 
>Blue appears baby-blue.  Red appears orangeish, and none of the
>fonts or icons are smooth.  Some text is invisible.  

My inclination is that this is a hardware problem, or perhaps a bad
video BIOS issue.  If it is a video driver or X server bug, I'd
suspect I'd receive many more reports, but this is the first
time I've heard of this since we shipped 4.3.0, which is why I'm
suspecting your hardware.  Have you filed a bug report in XFree86
bugzilla at http://bugs.xfree86.org by chance?

You might also want to discuss this on the xfree86@xfree86.org
mailing list.  If anyone else has this problem, you'll probably
encounter someone on the list.  Others may have additional
insight that might be useful for this problem.


> Installing the gatos driver (gatos.sf.net) makes the Xserver
> consistently think the monitor is a flat panel, preventing
> X from starting

Unfortunately, we do not support GATOS (or any other 3rd party
drivers - open or closed source, so I'm unable to assist with
that problem.  The GATOS project's mailing lists may be useful
though perhaps.


> and Option "CrtScreen" has no effect.

That option hasn't been valid since XFree86 4.2.1.  For a complete
list of "radeon" driver options, you may wish to review the radeon
and XF86Config manpages.

Note that the driver patch written by Hui Yu at ATI which improves
monitor autodetection by implementing DDC directly over i2c, instead
of using VBE, was not in XFree86 4.3.0 nor in Red Hat Linux 9's
4.3.0-2, but it has been present in our 4.3.0 builds for quite a
while now, and is included in Fedora Core.  This has nothing to do
with color representation however, it has to do with the driver
autodetecting what display ports have a display plugged into them
and wether it is a CRT or a DFP, etc..

I note that you are using 16 bit depth instead of 24 bit depth.
That will not look as nice as 24 bit depth does, and depending
on your specific display type, it may appear quite differently.
I strongly suggest using 24bit color depth to see if that makes
any difference for you.



Comment 5 Gregory Harris 2003-11-14 01:02:04 EST
> My inclination is that this is a hardware problem, or perhaps a bad
> video BIOS issue.  If it is a video driver or X server bug, I'd
> suspect I'd receive many more reports, but this is the first
> time I've heard of this since we shipped 4.3.0, which is why I'm

I feel pretty confident it is a video driver or an X server bug because:

1)  This is a multiboot system and Windows is running fine on it.
2)  Downloading and Installing the XF86 4.2.0 binaries over the fedora
install resolves the color issue.

The unfortunate consequence of doing (2) breaks all gnome/gtk and
redhat-config applications with the error:
  ImportError: /usr/lib/libfontconfig.so.1: undefined symbol:
FT_Get_PS_Font_Info

> suspecting your hardware.  Have you filed a bug report in XFree86
> bugzilla at http://bugs.xfree86.org by chance?

No, i have not, and I'm stumped too because I've done numerous
searches on the bugs there and on google and can't find anybody with a
similiar problem.  I will go ahead and file a report there.  In the
meantime, I am willing to help test any "experimental radeon drivers"
you may have (that work with core-1) to resolve this issue.

Thanks for the info about Hui Yu's patch, now i can go to gatos and
ask Vladimir to apply it to his code (because it doesn't detect the
DFP/LCD right, at least the driver on fedora's does though).

Despite this issue, I want to thank you for your efforts on the Fedora
project.  It runs flawlessly on my Inspiron 8500 notebook (which has a
radeon mobility chipset on it).  Hopefully i can get my desktop up and
running Fedora (in graphical mode) soon as well.

About the bit depth, It was on that because i was fiddling with 8-bit,
16, and 24bit and also xvidtune to see if I could get the color issue
resolved (sometimes sacrficing color and resolution makes X work).
Comment 6 Mike A. Harris 2003-11-14 13:10:06 EST
I've got practically every ATI Radeon model that ATI has produced,
although I do not have their 7500 AiW model.  I have an original
AiW though.  Any problem such as this shouldn't in any way be
model dependant though, so it should be reproduceable on any
card, at least in the same family.  ie: Radeon 7500

There are millions of these cards out there in use, and only 1 bug
report?  ;o)

Is your card "Built by ATI" or is it "Powered by ATI"?  It appears
to be a real "Built by ATI" card in your X log.

I'll try to reproduce this again next time I have a Radeon 7500
plugged into my test box, using your config file.

TIA
Comment 7 Gregory Harris 2003-11-14 17:45:23 EST
Good News!  My bug was marked a duplicate of several others in the
XF86 bugzilla...  Apparently I was looking in the wrong place, my
apologies.

Apparently this is a problem which starting cropping up in CVS around
2003 07-03  (see http://bugs.xfree86.org/show_bug.cgi?id=463), and has
been fixed in 2003 10-09 CVS.  Does the radeon driver used in Fedora
use some code from CVS around that time?  Apparently the binaries on
"Alan Hourihane's confidential binary snapshots page" work, whereever
that is.  I hope that upgrading to 4.3.99 won't cause the font-config
problems with fedora like downgrading to 4.2.0 did.  Any thoughts?
Comment 8 XShadow 2004-01-27 14:00:12 EST
I am having the same EXACT problem:

-- The colors are very washed. Gamma setting has no usable effect (if
too low it loses colors)
-- The resolution is very low (though I am in 1024x768). More
specifically font smoothing does not work.

Hardware:
ATi Radeon 9000 64MB

I tried various options in the XF86Config file but with no direct
brightness-lowering result.

What can I do? There is no fix or something?

-XShadow
Comment 9 Gregory Harris 2004-01-27 18:19:04 EST
XShadow, 

Try replacing the drivers, the drm kernel module, and the XFree86
binary with the ones at this page:

http://www.xfree86.org/~alanh

Using the ones posted on that website (which has the version and
release dates listed below) fixed the problem for me.

XFree86 Version 4.3.99.16
Release Date: 20 November 2003
Comment 10 XShadow 2004-01-28 02:38:05 EST
Downloaded the ATI native drivers (www.ati.com) and they work flawlessly.

All is working fine now. Brightness is normal, and fonts/icons are
smooth as they should be.

PS: Probably the ATI drivers are more stable than the XFree86
EXPERIMENTAL ones. ;)
Comment 11 Jef Spaleta 2004-01-29 11:16:12 EST
I'm going to go ahead and mark this as closed upstream.
Since this conversation has mentioned relevant upstream bug reports.

Comment 12 Mike A. Harris 2004-01-29 16:31:32 EST
Additionally..  while this problem appears now to be solved in
upstream XFree86, if someone is willing to determine the exact
*small* patch to fix _just_ this problem, I'm more than happy to
include that in a future update for 4.3.0.  I wont throw in any
large patches or wholesale driver updates as that tends to add
just as many new bugs as it fixes, and new regressions are not
acceptable for 4.3.0 updates.

So, if someone isolates the single small fix that makes this
problem go away, feel free to reopen this earlier and I'll review
it for consideration.

TIA
Comment 13 Mike A. Harris 2004-06-24 12:50:06 EDT
A fix for a similar issue is present for Radeon 9200 hardware in
the latest FC1 update.  The problem was caused by an ASIC or BIOS
bug if I recall correctly, and is worked around in the driver.  This
same problem may be present on the card reported in this report.

You may wish to test the latest update to see if this problem is still
present for you or not.  If the problem is present still, try
upgrading to Fedora Core 2 with X.Org X11 which contains the
XFree86 fix mentioned above.

Closing as 'CURRENTRELEASE' of FC2.

Note You need to log in before you can comment on or make changes to this bug.