Bug 109958 - error message when adding IP service
error message when adding IP service
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
3.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jim Parsons
James Laska
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 08:43 EST by Nguyen Ngoc Can
Modified: 2013-09-02 01:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 16:26:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes language translation issue causing 'ifconfig' output to show different text in different languages (725.61 KB, application/x-rpm)
2003-11-13 17:14 EST, Hardy Merrill
no flags Details

  None (edit)
Description Nguyen Ngoc Can 2003-11-13 08:43:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.2.1)
Gecko/20030225

Description of problem:
error message "IP address not on same network as this host" when
adding IP service (service NFS and Samba for ex)

Version-Release number of selected component (if applicable):
clumanager-1.2.3-1.i386

How reproducible:
Always

Steps to Reproduce:
1. with cluster-config, click on button "+ child"
2. add IP service
3. after adding ip service and valid by OK, error message "IP address
not on same network as this host"
    

Actual Results:  error

Expected Results:  add really IP service without error message

Additional info:
Comment 2 Hardy Merrill 2003-11-13 12:08:08 EST
Problem appears to be a translation issue - redhat-config-cluster
executes '/sbin/ifconfig' and parses the output to get ip addresses
and such.  The parse logic looks for 'inet addr', but the ifconfig in
French produces 'inet adr' - minus one 'd'.  I'm working on a fix for
this.

In the meantime, please try this workaround:
  # export LC_ALL=C
  # redhat-config-cluster
Comment 3 Hardy Merrill 2003-11-13 17:14:29 EST
Created attachment 95957 [details]
Fixes language translation issue causing 'ifconfig' output to show different text in different languages

Please try this rpm (redhat-config-cluster-1.0.1-2.noarch.rpm) and see if it
stops the "IP Address not on the same network" messages from coming up when you
add an ip address or a member.

Please test and post results back here as-soon-as-possible since 11/14/2003
12noon is the freeze for a respin of Red Hat Cluster Suite.
Comment 4 Hardy Merrill 2003-11-13 17:54:30 EST
Just to make sure all the necessary bug information is logged here,
this is 'ifconfig' output from the French locale system sent to me by
Bastien Nocera:

eth0      Lien encap:Ethernet  HWaddr 00:0B:DB:D5:1C:84
          inet adr:153.109.10.26  Bcast:153.109.10.255 
Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:65920 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33753 errors:0 dropped:0 overruns:0 carrier:0
          collisions:72 lg file transmission:1000
          RX bytes:5323773 (5.0 Mb)  TX bytes:8018330 (7.6 Mb)
          Interruption:28

eth1      Lien encap:Ethernet  HWaddr 00:0B:DB:D5:1C:85
          inet adr:192.168.1.1  Bcast:192.168.1.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:704 (704.0 b)
          Interruption:29

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:11555 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11555 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:663526 (647.9 Kb)  TX bytes:663526 (647.9 Kb)
Comment 5 Thierry Bagnoud 2003-11-14 03:28:03 EST
I use a french local system.

it's OK with redhat-config-cluster-1.0.1-2.noarch.rpm, the error
message don't appears if I add an IP for the service or add a member.

The command ifconfig show always 'inet adr'

eth0      Lien encap:Ethernet  HWaddr 00:0B:DB:D5:1C:84  
          inet adr:153.109.10.26  Bcast:153.109.10.255 
Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:128865 errors:0 dropped:0 overruns:0 frame:259
          TX packets:47993 errors:2 dropped:0 overruns:0 carrier:0
          collisions:916 lg file transmission:1000 
          RX bytes:17566470 (16.7 Mb)  TX bytes:6544149 (6.2 Mb)
          Interruption:28 
 
eth1      Lien encap:Ethernet  HWaddr 00:0B:DB:D5:1C:85  
          inet adr:192.168.1.1  Bcast:192.168.1.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          RX bytes:856 (856.0 b)  TX bytes:3024 (2.9 Kb)
          Interruption:29 
 
lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3226 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3226 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:190116 (185.6 Kb)  TX bytes:190116 (185.6 Kb)


Thierry Bagnoud
Comment 6 Hardy Merrill 2003-11-14 09:06:08 EST
I've committed redhat-config-cluster-1.0.1-2.noarch.rpm into the build
system so it should appear in the next errata.
Comment 7 Suzanne Hillman 2004-01-14 16:26:49 EST
Verified and closing as errata.

(To set a machine to French, export LC_ALL=fr_FR)

Note You need to log in before you can comment on or make changes to this bug.