Bug 10997 - BUG IN DYNAMIC LINKER
Summary: BUG IN DYNAMIC LINKER
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-23 04:08 UTC by urbanlee
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 14:49:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description urbanlee 2000-04-23 04:08:06 UTC
Hi,

  I was trying to install RealServer7 Plus on RH Linux 6.1/Intel and
  getting following  error:

  BUG IN DYNAMIC LINKER ld.so: dynamic-link.h: 57: elf_get_dynamic_info:
  Assertion `! "bad dynamic tag"' failed!

  I checked ls.so.conf:

        /usr/X11R6/lib
        /usr/i486-linux-libc5/lib
        /usr/lib

  Any solution to fix this is aprreciated.

Comment 1 Jeff Johnson 2000-05-15 14:21:59 UTC
What does "rpm -qf /lib/ld-*" say?

What is the affected file?
What does "file <bad_file_here>" say?
What does "objdump -x <bad_file_here>" say?
You might want to send a copy of the file as well, as that will insure
that we can reproduce your problem.

You might also check for an updated RealServer7 Plus package, as I suspect
the cause might be in the executable rather than in the Linux software.
Just a guess ...

Comment 2 Cristian Gafton 2000-05-22 14:49:59 UTC
assigned to jakub

Comment 3 Jakub Jelinek 2001-11-08 18:44:33 UTC
If you have any details, please reopen.


Note You need to log in before you can comment on or make changes to this bug.