Bug 109970 - LTC5294-redhat-config-packages doesn't allow removal of 'standard' packages
LTC5294-redhat-config-packages doesn't allow removal of 'standard' packages
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-packages (Show other bugs)
3.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 10:54 EST by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 16:22:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-11-13 10:54:50 EST
The following has be reported by IBM LTC:  
redhat-config-packages doesn't allow removal of 'standard' packages
Hardware Environment: iSeries 64bit

Software Environment: RHEL 3 GA - redhat-config-packages


Steps to Reproduce:
1. Start redhat-config-packages
2. Attempt to remove the 'Office/Productivity' package group.  (This
is just an 
example group.  The problem can be recreated with a number of other
package 
groups.
3. It will complain that the kdepim package (part of the office and 
productivity package group) is required by kdenetwork
4. Go to the 'KDE Desktop Environment' package group and note that 
the 'kdenetwork' package is a 'standard' package.
5. Attempt to remove the package to resolve the dependency issue.

Actual Results:
Because the 'kdenetwork' package is a 'standard' package I am unable
to remove 
it.  I would have to remove the whole 'KDE Desktop Environment' group
to remove 
this package.  At this point I run into many more standard
applications that 
require various packages.  In short, it is nearly impossible to remove
some 
packages and package groups.

Expected Results:
I expect to be able to remove any packages that require the one I am
attempting 
to remove.  I want to be able to remove a package and any associated 
applications that are affected.

Additional Information:
Bug 5293 is related to this problem.  I am marking it as a
dependent.Glen / Greg / Mark,
Please report problem to RedHat.   Mike Ranweiler says to push this
one harder 
than 5293
Comment 1 Suzanne Hillman 2003-12-15 15:33:12 EST
Internal RFE bug #112184 entered - will be looked at for future releases.
Comment 2 IBM Bug Proxy 2004-01-06 10:01:50 EST
------ Additional Comments From khoa@us.ibm.com  2004-01-06 03:39 -------
Based on Red Hat's comment above, set the resolution of this bug to 
"Will_Fix_Later". 
Comment 3 IBM Bug Proxy 2004-01-21 21:38:29 EST
----- Additional Comments From sloanj@us.ibm.com  2004-01-21 11:36 -------
Problem still exists, as expected in RHEL 3 QU1 
Comment 4 IBM Bug Proxy 2004-01-23 23:46:13 EST
----- Additional Comments From khoa@us.ibm.com  2004-01-23 09:37 -------
Mark / Glen - can you find out from Red Hat what future release this will
be fixed ?  THanks. 
Comment 5 IBM Bug Proxy 2004-01-30 16:03:35 EST
----- Additional Comments From khoa@us.ibm.com  2004-01-30 15:50 -------
I've put this on the RHEL3 Update3 list as a Sev 1. 
Comment 6 IBM Bug Proxy 2004-03-26 07:30:22 EST
----- Additional Comments From khoa@us.ibm.com  2004-03-26 07:32 -------
Red Hat reported that this will be fixed in the upcoming RHEL3 U2. 
Comment 7 IBM Bug Proxy 2004-04-13 19:51:16 EDT
----- Additional Comments From pbowen@us.ibm.com  2004-04-13 19:53 -------
Ray - you or Joe please attempt to verify Thanks. 
Comment 8 IBM Bug Proxy 2004-04-21 18:12:13 EDT
----- Additional Comments From sloanj@us.ibm.com  2004-04-21 18:15 -------
Attempted with RHEL3 QU2,  removed the office/productivity group (and other 
groups).  And was prompted with "Package not found error" for kdepim (required 
by kdenetwork).  The kdepim package is in the KDE Desktop Environment group 
now.  So I added the kdepim package and got past this dependency problem. 
Comment 9 IBM Bug Proxy 2004-04-21 18:16:22 EDT
----- Additional Comments From sloanj@us.ibm.com  2004-04-21 18:16 -------
closing bug 
Comment 16 Jeremy Katz 2006-09-25 16:22:01 EDT
This should be much better in pirut in RHEL5

Note You need to log in before you can comment on or make changes to this bug.