This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 109987 - Error informing the kernel about modifications to partition /dev/hda1 - Device or resource busy
Error informing the kernel about modifications to partition /dev/hda1 - Devic...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 13:21 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 15:28:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda dump file (606.00 KB, text/plain)
2003-11-13 13:23 EST, Need Real Name
no flags Details
Here is the dump file for the error I just described. Hope it helps. (600.82 KB, text/plain)
2004-02-12 12:24 EST, Justin Bronn
no flags Details

  None (edit)
Description Need Real Name 2003-11-13 13:21:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007

Description of problem:
After confirming I want to continue to install using Fedora Disk #1
and #2 (should be nearly the final step I guess), a dialog showing the
following message appeared:

Error: Error informing the kernel about modifications to partition
/dev/hda1 - Device or resource busy.  This means Linux won't know
about any changes you made to /dev/hda1 until you reboot - so you
shouldn't mount it or use it in any way before rebooting.

No matter I select 'Ignore' or 'Continue', the installer force me to
reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Perform installation using the following options:
1. Language Selection: Default [English(English)]
2. Keyboard Configuration: Default [US English]
3. Mouse Configuration: 2 Button Mouse (PS/2) (Fedora wrongly
recognized it as 3 Button)
4. Installation Type: Personal Desktop
5. Disk Partition Setup: Manual (see Additional Information)
6. Boot Loader Config: Default
7. Boot Loader Advanced Config: Default
8. Network Config: Default
9. Firewall Config: Default
10. Additional Language Support: Default
11. Time zone selection: Asia/Hong_Kong
12. Set Root Password: *******
13. Package Installation Defaults: Default
14. Error occur after confirming installation
    

Actual Results:  Error message box appeared

Expected Results:  Installation continues

Additional info:

I doubt Fedora does not support my partition setup:

Disk /dev/hda: 255 heads, 63 sectors, 5606 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1       580   4658818+  a5  FreeBSD
/dev/hda2           581       988   3277260   82  Linux swap
/dev/hda3   *       989      1021    265072+   b  Win95 FAT32
/dev/hda4          1022      5606  36829012+   f  Win95 Ext'd (LBA)
/dev/hda5          1022      1023     16033+  83  Linux
/dev/hda6          1024      1913   7148893+   7  HPFS/NTFS
/dev/hda7          1914      1984    570276   83  Linux
/dev/hda8          1985      2495   4104576   83  Linux
/dev/hda9          2496      3388   7172991   83  Linux
/dev/hda10         3389      3519   1052226   4d  QNX4.x
/dev/hda11         3520      3620    811251    b  Win95 FAT32
/dev/hda12         3621      4605   7911981   8e  Linux LVM
/dev/hda13         4606      5544   7542486   8e  Linux LVM
/dev/hda14         5545      5606    497983+  82  Linux swap

I told it to install / to hda8, swap to hda14, tried telling it to
format and also tried telling it not to format.
It warned me about the 1024 cylinder issue and I ignored it.

Anyway, it shouldn't touch hda1
Comment 1 Need Real Name 2003-11-13 13:23:45 EST
Created attachment 95949 [details]
Anaconda dump file
Comment 2 Eugene A. Simonenko 2003-12-06 16:32:30 EST
Error with FreeBSD partition! I have /dev/hda4 with FreeBSD. I can't 
install Fedora!
Comment 3 Troy Dawson 2004-01-08 10:14:19 EST
I hate being a 'me too', but I also have that error, but it comes
about in a different way.
I have a machine with two very large raid arrays, so they look like two
1.5 Terrabye drives, both with just one large partition on them.  They
had already been partitioned before trying this install.
I didn't do anything to them.  I didn't assign the paritions names, or
touch them in any way in disk druid, yet I got the same error as
above, except that it says /dev/sdb1 instead of /dev/hda1.

In tracking this down and trying to find a way around it, I got into
F2, and found that if I tried to repartition using parted, it just
barfed if my partitions went above the 1 Terrabyte limit.  But I was
able to use fdisk just fine.
Comment 4 Justin Bronn 2004-02-12 12:24:08 EST
I also have this error, with a 1.5TB RAID5 array with a 3ware 8506-8
Serial ATA card.  Get the same error as the first poster:

Error: Error informing the kernel about modifications to partition
/dev/sda1 - Device or resource busy.  This means Linux won't know
about any changes you made to /dev/sda1 until you reboot - so you
shouldn't mount it or use it in any way before rebooting.same error as
the first poster, with 
Comment 5 Justin Bronn 2004-02-12 12:24:56 EST
Created attachment 97621 [details]
Here is the dump file for the error I just described.  Hope it helps.
Comment 6 Al Thilk 2004-02-27 14:06:24 EST
Received same error almost to the letter as described in initial     
     report. My error is also with FreeBSD partition. It's version 5.1.

Interestingly enough I also have problem trying to Install RHL 9.0. 

I also have multiple partitions created, probably the same way as the
initial report, using CFDISK to allow making 3 Primary Partitions, an
Extended Partition and Multiple Logical Partitions. 

During Partitioning DiskDruid also complains but says error can be
ignored and later on there is a warning about a Boot Sector problem
which also can be ignored. 

Previously I had the FreeBSD on a physical Disk of it's own and Fedora
installed without problems.

No other Distro has a problem so it appears bug is somewhere in
anaconda and DiskDruid.
Comment 7 KNMI Linux Admin 2004-04-05 08:21:16 EDT
Hello,

More additions I'm afraid: we've had the same trouble at KNMI with:

HP DL360 + BROWNIE U160SCSI/IDE RAID5 vault + RH7.3
DELL 2650 + DELL PV220s + RH9
HP XW6000 workstation + BROWNIE U160SCSI/IDE RAID5 vault + RHEL WS3.0
HP XW6000 workstation + BROWNIE U160SCSI/IDE RAID5 vault + RH9

Workaround always is to disconnect or poweroff the vault(s), do the
install or kickstart, reboot/poweron the vaults.

I agree that it is a bug in anaconda/DiskDruid. The only common factor
at our site seems to be: RedHat/anaconda/RAID-vault/large filesystem
with ext3. 
Comment 8 Jeremy Katz 2004-06-25 15:28:29 EDT
This should be better in the devel tree now.

Note You need to log in before you can comment on or make changes to this bug.