Bug 1099980 - Publican don't works on Ubuntu after the last update of Ubuntu
Publican don't works on Ubuntu after the last update of Ubuntu
Status: CLOSED DUPLICATE of bug 1099639
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On: 1099639 1099643 1105011
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-21 13:24 EDT by Gé Baylard
Modified: 2014-06-24 10:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-28 23:28:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gé Baylard 2014-05-21 13:24:12 EDT
Description of problem:
The build of the translated XML works.
But the buid of the final html fails.

Version-Release number of selected component (if applicable):


How reproducible:
Install the last update of Ubuntu.
Install the publican tree.
Il you run:
publican build --formats=html(-single) --langs=fr-FR (--quiet)

Steps to Reproduce:
1.
2.
3.

Actual results:
Terminal message:

FreeIPA_Guide.xml:6: validity error : No declaration for element book
FreeIPA_Guide.xml:6: validity error : No declaration for attribute lang of element book
Book_Info.xml:6: validity error : No declaration for element bookinfo
Book_Info.xml:6: validity error : No declaration for attribute lang of element bookinfo
......
Conventions.xml:39: validity error : No declaration for element entry
Conventions.xml:42: validity error : No declaration for element entry
Conventions.xml:49: validity error : No declaration for element tbody
Conventions.xml:50: validity error : No declaration for element row
Conventions.xml:50: validity error : No declaration for attribute valign of element row
Conventions.xml:51: validity error : No declaration for element entry
Conventions.xml:53: validity error : No declaration for element screen
Conventions.xml:56: validity error : No declaration for element entry


Expected results:
Nothing on the terminal.
The build of the html file

Additional info:
Was working fine before update.
Comment 1 Jeff Fearn 2014-05-22 01:55:28 EDT
FYI: This was discussed  on the mailing list [1] it's about RHEL6 but it's the same issue.


https://www.redhat.com/archives/publican-list/2014-May/msg00006.html
Comment 2 Jeff Fearn 2014-05-28 23:28:13 EDT

*** This bug has been marked as a duplicate of bug 1099639 ***
Comment 3 Damien Regad 2014-06-02 08:30:58 EDT
Hi Jeff

Sorry to post on a closed issue, but I'm facing the same issue as well, and did not want to create another duplicate (bugzilla says I am not authorized to access bug #1099639 - Why ?).

The error occurs both on my local dev box (Ubuntu 14.04 / publican 3.2.1) as well as on a server where I have automated builds setup (Ubuntu server 10.04 / publican 0.99).

Looking at the apt history log since the last successful build, it appears that libxml2 library was upgraded, which I guess confirms this is indeed the same issue described in the mailing list post you referenced above:

Start-Date: 2014-05-15  15:17:00
Upgrade: python-libxml2 (2.7.6.dfsg-1ubuntu1.10, 2.7.6.dfsg-1ubuntu1.11), libxml2 (2.7.6.dfsg-1ubuntu1.10, 2.7.6.dfsg-1ubuntu1.11), libxml2-utils (2.7.6.dfsg-1ubuntu1.10, 2.7.6.dfsg-1ubuntu1.11)
End-Date: 2014-05-15  15:17:04

For the benefits of other users, I fixed the problem by downgrading libxml2 to the previous version:

# apt-cache show libxml2 |grep Version
Version: 2.7.6.dfsg-1ubuntu1.11
Version: 2.7.6.dfsg-1ubuntu1
# apt-get install libxml2=2.7.6.dfsg-1ubuntu1
# echo libxml2 hold |dpkg --set-selections
Comment 4 Jeff Fearn 2014-06-02 18:55:34 EDT
(In reply to Damien Regad from comment #3)
> Hi Jeff
> 
> Sorry to post on a closed issue, but I'm facing the same issue as well, and
> did not want to create another duplicate (bugzilla says I am not authorized
> to access bug #1099639 - Why ?).

I don't know why that bug had limited access, I removed the limit.

Thanks for the work around.
Comment 5 Damien Regad 2014-06-24 10:09:20 EDT
Jeff,

#1105011 is also restricted access...

For those interested, the libxml2 bug has been patched in Ubuntu, see
https://lists.ubuntu.com/archives/ubuntu-security-announce/2014-June/002542.html

Damien

Note You need to log in before you can comment on or make changes to this bug.