Bug 110014 - up2date trace back on AS2.1 system
up2date trace back on AS2.1 system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 18:21 EST by Fred Shaul
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 12:25:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Shaul 2003-11-13 18:21:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007

Description of problem:
On RHAS2.1 system, downloaded latest up2date and rhn_network.  Now
when I try and run up2date get traceback error


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
On RHAS2.1 system, downloaded latest up2date and rhn_network.  Now
when I try and run up2date get traceback error

# up2date -l

Boom!

# rpm -q python rpm rpm-python gnupg sh-utils rhn_register mkinitrd
python-xmlrpc
python-1.5.2-38
rpm-4.0.4-7x.20
rpm-python-4.0.4-7x.20
gnupg-1.0.6-3
sh-utils-2.0.11-5
rhn_register-2.8.34-1.2.1AS
mkinitrd-3.2.6-1
python-xmlrpc-1.5.1-7.x.3


Actual Results:  [root@moby root]# up2date -l
Traceback (innermost last):
  File "/usr/sbin/up2date", line 781, in ?
    main()
  File "/usr/sbin/up2date", line 569, in main
    pkgNames, fullUpdate, dryRun = dry_run))
  File "/usr/sbin/up2date", line 724, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 57, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 89, in
__findPackagesToUpdate
    plist.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 85, in run
    self.addObsoletePackages(obsList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 109, in
addObsoletePackages
    for p in obsoletePackages:
TypeError: loop over non-sequence
[root@moby root]# rpm -q rhn_register
rhn_register-2.8.34-1.2.1AS
[root@moby root]#

Expected Results:  should work!

Additional info:

This may be due to not a mix of entitlements for our company - perhaps
the AS2.1 entitilement isn't being granted to the up2date request and
it is bombing in a non-friendly fashion?
Comment 1 Adrian Likins 2004-09-02 12:25:43 EDT
This is due to the machine in question not being properly 
assigned to any channels. If you check it via the RHN web
site, you should be able to manually assign it a channel
if you have available entitlements.

Newer versions of the client code also present a more
meaningful error in this case.

Note You need to log in before you can comment on or make changes to this bug.