Bug 110061 - tsclient segfaults when connecting via rdp
tsclient segfaults when connecting via rdp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tsclient (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 11:27 EST by Alejandro Gonzalez Hernandez - Imoq
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.132-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 08:23:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of the command. (26.47 KB, text/plain)
2003-11-14 11:32 EST, Alejandro Gonzalez Hernandez - Imoq
no flags Details

  None (edit)
Description Alejandro Gonzalez Hernandez - Imoq 2003-11-14 11:27:31 EST
Description of problem:

Whenever I use tsclient to connect to an RDP host it gives a
"Segmentation fault".

Using "rdesktop <ip>" works well.

Version-Release number of selected component (if applicable):


[imoq@imoqland imoq]$ rpm -q tsclient
tsclient-0.120-1
[imoq@imoqland imoq]$ rpm -q rdesktop
rdesktop-1.2.0-2
[imoq@imoqland imoq]$


How reproducible:

Always.

Steps to Reproduce:
1. run "tsclient"
2. type an IP address that supports rdp protocol

  
Actual results:

Program crashes, segmentation fault.

Expected results:

Connect to remote host.
Comment 1 Alejandro Gonzalez Hernandez - Imoq 2003-11-14 11:32:55 EST
Created attachment 95973 [details]
strace of the command.
Comment 2 Tim Fournet 2003-12-02 09:46:47 EST
I get the same thing. It does, however, work properly when I execute
tsclient as root. 
Comment 3 Tim Fournet 2003-12-04 09:06:37 EST
It also segfaults when trying to use VNC to connect, so apparently the
problem is not related to rdesktop. 
Comment 4 Kaj J. Niemi 2003-12-08 15:39:40 EST
Unable to reproduce using RDP. I use it daily to connect to Win2K and
Win2K3 servers.

% ldd /usr/bin/tsclient | awk '{print $3}' | xargs -n 1 rpm -qf | sort -u
atk-1.4.0-1
audiofile-0.2.3-7
e2fsprogs-1.35-2
esound-0.2.31-1
expat-1.95.5-3
file /lib/libcrypto.so.4 is not owned by any package
file /lib/libssl.so.4 is not owned by any package
fontconfig-2.2.1-6.1
freetype-2.1.4-5
GConf2-2.4.0-1
glib2-2.2.3-1.1
glibc-2.3.3-1
gnome-panel-2.4.0-3
gnome-vfs2-2.4.1-1
gtk2-2.2.4-5.2
krb5-libs-1.3.1-7
libart_lgpl-2.3.16-1
libbonobo-2.4.0-1
libbonoboui-2.4.0-1
libglade2-2.0.1-5.1
libgnome-2.4.0-1
libgnomecanvas-2.4.0-1
libgnomeui-2.4.0.1-1
libjpeg-6b-29
libxml2-2.6.2-4
ORBit2-2.8.2-1
pango-1.2.5-1.1
popt-1.8.1-0.30.1
XFree86-libs-4.3.0-45
zlib-1.2.1-1
Comment 5 Michael Honeyfield 2003-12-08 18:56:14 EST
I am currently only getting the seg fault when attempting vnc 
connections. So far I am yet to get a seg fault using RDP. I have not 
tested XDMCP yet. I plan to do some heavier testing over the course 
of this week.

Thanks

Mike
Comment 6 Michael Honeyfield 2003-12-08 20:58:10 EST
updating to 0.132 fixes the connection to vncserver seg fault. I will 
test thr RDP and RDPv5 connections tomorrow. 

I also have a new srpm for tsclient
Comment 7 David Jansen 2004-01-22 12:44:56 EST
I get the segmentation faiults too. My version is tsclient-0.120-1 as
was reported earlier. Where is this 0.132 rpm which should fix the
problem?

However: clicking on the "more" button and filling in hostname and
username there makes it work! 
Comment 8 Michael Honeyfield 2004-01-22 13:34:31 EST
I have a srpm of the latest tsclient. I posted to the dev list that I 
had it and that it fixed this issue. No responed. I am not aware of 
what the process is on submitting fixes. 

Mike
Comment 9 Mark McLoughlin 2004-02-19 08:23:17 EST
Michael: apologies for the lack of response - the package had been
more or less orphaned.

0.132-1 should appear in rawhide soon. Re-open if that doesn't fix the
problem.

* Wed Feb 18 2004 Mark McLoughlin <markmc@redhat.com> 0.132-1
- Update to 0.132


Note You need to log in before you can comment on or make changes to this bug.