Bug 110098 - STL allocator using new/delete not supported in current g++ 2.96
STL allocator using new/delete not supported in current g++ 2.96
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: gcc (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 15:18 EST by Kevin Krafthefer
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
port v3 __new_alloc to v2, make default allocatore use it (2.96 KB, patch)
2003-11-24 12:28 EST, Benjamin Kosnik
no flags Details | Diff

  None (edit)
Description Kevin Krafthefer 2003-11-14 15:18:22 EST
Description of problem:
STL allocator using new/delete not supported in current g++ 2.96

Version-Release number of selected component (if applicable):
2.96

How reproducible:
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs gcc
version 2.96 20000731 (Red Hat Linux 7.2 2.96-108.1)

And the STL implementation under /usr/include/g++-3 seems not to have
the allocator types which used new/delete inside. This made our
overloading new/delete operator in OLAPI code not useful since we're
implemenating our own new/delete to do memory allocation so that in
shared server mode, we can allocate memory from UGA heap.

I found following site:

@
http://gcc.gnu.org/onlinedocs/libstdc++/libstdc++-html-USERS-3.3/stl__alloc_8h-source.html

Steps to Reproduce:
1. gcc
2.
3.
  
Actual results:


Expected results:


Additional info:
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs gcc
version 2.96 20000731 (Red Hat Linux 7.2 2.96-108.1)

And the STL implementation under /usr/include/g++-3 seems not to have
the allocator types which used new/delete inside. This made our
overloading new/delete operator in OLAPI code not useful since we're
implemenating our own new/delete to do memory allocation so that in
shared server mode, we can allocate memory from UGA heap.

I found following site:

@
http://gcc.gnu.org/onlinedocs/libstdc++/libstdc++-html-USERS-3.3/stl__alloc_8h-source.html
Comment 1 Kevin Krafthefer 2003-11-14 15:19:02 EST
IT_27178
Comment 2 Jakub Jelinek 2003-11-17 06:44:05 EST
libstdc++ in GCC 2.96-RH and earlier compilers certainly is not ISO C++ conforming.
This should be considered as feature request.
Comment 3 Benjamin Kosnik 2003-11-24 12:28:41 EST
Created attachment 96154 [details]
port v3 __new_alloc to v2, make default allocatore use it
Comment 4 Benjamin Kosnik 2005-04-25 11:44:36 EDT
This toolchain is frozen. This kind of fundamental change is not going to fly.

Suggest using gcc-3.4/gcc-4.0 version of compiler/libstdc++. That has a
new-based std::allocator by default, as well has high-performance options.

-benjamin
Comment 5 RHEL Product and Program Management 2007-10-19 15:23:45 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.