Bug 110137 - OpenOffice displays a "scrunched" Nimbus Sans L
OpenOffice displays a "scrunched" Nimbus Sans L
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 20:37 EST by J. J. Ramsey
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 16:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of scrunched Nimbus Sans L (14.77 KB, image/png)
2003-11-14 20:38 EST, J. J. Ramsey
no flags Details
Screenshot of unscrunched Nimbus Sans L (19.90 KB, image/png)
2003-11-14 20:39 EST, J. J. Ramsey
no flags Details
place this file in /usr/bin/ooffice, replacing what's currently there (8.69 KB, text/plain)
2004-03-17 16:59 EST, Dan Williams
no flags Details

  None (edit)
Description J. J. Ramsey 2003-11-14 20:37:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
OpenOffice sometimes displays Nimbus Sans L as a condensed font, and
sometimes not. Deleting ~/.openoffice/user/psprint/pspfontcache
restores Nimbus Sans L to its unscrunched state.


Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-6
Comment 1 J. J. Ramsey 2003-11-14 20:38:49 EST
Created attachment 95988 [details]
Screenshot of scrunched Nimbus Sans L
Comment 2 J. J. Ramsey 2003-11-14 20:39:43 EST
Created attachment 95989 [details]
Screenshot of unscrunched Nimbus Sans L
Comment 3 Dan Williams 2004-02-27 11:47:51 EST
Please try current OOo 1.1.0, and reopen if problem still occurs
Comment 4 J. J. Ramsey 2004-02-27 12:19:38 EST
What current OOo 1.1.0? The latest version of the Fedora RPM of OOo is
still 1.1.0-6. Also, whereas on Red Hat 9, xfontsel on Red Hat 9
showed both the condensed and normal versions of the Nimbus Sans L
font, xfontsel only shows the normal version of the font--and the
files for both variants of the font are on the system.

BTW, I suggest that you look at a probably related bug "Nimbus Sans is
only displayed condensed in AbiWord"
<https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=109908>

Looks like there are problems all around getting the "condensed" vs.
"normal" stuff straight.
Comment 5 Dan Williams 2004-02-27 15:30:25 EST
I mean latest OOo in rawhide.  That is openoffice.org-1.1.0-28
Comment 6 J. J. Ramsey 2004-02-27 19:39:38 EST
Given that I did *not* want to install the whole of Rawhide, I crossed
my fingers and tried installing the Rawhide version of the
openoffice.org RPM (1.1.0-28) on regular old Fedora Core 1.
Unfortunately, it had dependencies that apparently are only satisfied
by Rawhide, namely libgnomecups >= 0.1.6-1, libdb_cxx-4.2.so, and
libgnomecups-1.0.so.1. AFAIK, Fedora Core 1 doesn't even have the
libgnomecups package.

Looks like verifying this bug fix means getting closer to the bleeding
edge than I really want to go.
Comment 7 Dan Williams 2004-03-17 15:43:39 EST
j.j., can you attempt to install the RPMs at this address please?  You
will not have to install anything else...

http://people.redhat.com/dcbw/ooo-rh9/

Thanks!
Comment 8 J. J. Ramsey 2004-03-17 16:26:45 EST
> "j.j., can you attempt to install the RPMs at this address please? 
You will not have to install anything else..."

The RPMS install, but OpenOffice dies with

"'/usr/lib/ooo-1.1.0/program/setup
-R:/etc/openoffice/autoresponse.conf -v -nogui >&
~/.openoffice-install-log'"

.openoffice-install-log says:

"/usr/lib/ooo-1.1.0/program/setup.bin: error while loading shared
libraries: libsb645li.so: cannot open shared object file: No such file
or directory"

The file /usr/lib/ooo-1.1.0/program/libsb645li.so does exist, BTW.
Comment 9 Dan Williams 2004-03-17 16:57:54 EST
Erg... Could you modify the /usr/bin/ooffice script as follows?

        WriteVersionFile %config if ($changed);
    }
    # We can safely do the installation now
#----- INSERT THESE TWO LINES
    # We also must make sure setup can find the libraries it needs
    my $setup_cmd =
"LD_LIBRARY_PATH=$SystemInstallDir:$SystemInstallDir/program
$SetupProgram -R:$SetupConfig -v -nogui";
#-----
    if (!$Debug) {
	$setup_cmd .= " >& ~/.openoffice-install-log";
    }
Comment 10 Dan Williams 2004-03-17 16:58:24 EST
Hmm, sorry, don't insert but just modify the "my $setup_cmd" line to
be as it looks above.  That will work.
Comment 11 Dan Williams 2004-03-17 16:59:01 EST
Ah, actually just download and use the /usr/bin/ooffice file I will
attach here.
Comment 12 Dan Williams 2004-03-17 16:59:35 EST
Created attachment 98627 [details]
place this file in /usr/bin/ooffice, replacing what's currently there
Comment 13 J. J. Ramsey 2004-03-17 18:27:34 EST
> Created an attachment (id=98627)
> place this file in /usr/bin/ooffice, replacing what's currently there

That worked, mostly. Nimbus Sans L displays properly, but Avant Garde
Gothic is wrong, though. It looks exactly like Nimbus Sans L, when it
should look much closer to URW Gothic L.

If you run man -t grops > grops.ps, and then view grops.ps, you should
get a good idea of the difference between Avant Garde and Helvetica
(a.k.a. Nimbus Sans L). Also see
<http://www.adobe.com/type/browser/P/P_212.jhtml>.
Comment 14 Dan Williams 2004-09-25 16:33:16 EDT
This stuff is most likely fixed in latest Rawhide versions, but that
is not going to get backported to RH9... :(  Closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.