Bug 110152 - new glibc appears to break parts of gtk2 installation
Summary: new glibc appears to break parts of gtk2 installation
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-15 13:12 UTC by gazz
Modified: 2016-11-24 15:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-05 23:39:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description gazz 2003-11-15 13:12:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
glibc-2.3.2-27.9.7 (and common/devel) updated using the up2date
installer. 
immediately after this, i tried to start gnome-terminal (which had
been working previously).......problem as follows:

gnome-terminal: relocation error: gnome-terminal: undefined symbol:
gtk_window_set_auto_startup_notification


and in other apps, gtk themes are gone such as gnome-volume-control:

Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",


currently running gtk2-2.2.1-4,gtk2-engines-2.2.0-2,gtk+2-2.1.0-0
if that's of any help

Version-Release number of selected component (if applicable):
glibc-2.3.2-27.9.7

How reproducible:
Always

Steps to Reproduce:
1. use up2date to install new glibc
2. start gnome-terminal from panel or command line

    

Actual Results:  starting from the panel, i get a "starting terminal"
item on my window list, which hangs around for 10-15 seconds.....then
nothing :/

Expected Results:  gnome-terminal should've started :D

Additional info:

gnome-terminal: relocation error: gnome-terminal: undefined symbol:
gtk_window_set_auto_startup_notification
-----------------------------------------------
Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",



just wondering if anyone else's got a similar thing

Comment 1 Jakub Jelinek 2003-11-17 11:38:16 UTC
It certainly works for me.
Can you LD_DEBUG=all LD_DEBUG_OUTPUT=/tmp/gnome-terminal.log \ gnome-terminal
readelf -Ws /usr/lib/libgtk-x11-2.0.so.0 | grep auto
and attach /tmp/gnome-terminal.log* and output of the second command?



Note You need to log in before you can comment on or make changes to this bug.