Bug 110159 - File roller crashes every time I try to extract files from wine tarball
File roller crashes every time I try to extract files from wine tarball
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2003-11-15 10:41 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-28 05:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-15 10:41:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:
Extracting wine source tarballs with file-roller does not works for
me. Every time I press the extract button, I choose the location for
the extraction, then press the  OK button (leaving default options in
the dialog).

It crashes at that point. I then see a segfautl dialog. 

It seems to work with some packages and not to work with some others...
I tried with xine source without problems. I tried with
gaim-0.72.tar.gz (from sourceforge) and it crashes too

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Download wine source:
2. Open nautilus
3. Double click on wine-20031006.tar.gz
4. Press the extract button in file-roller
5. Choose directory, leave default options (all files, create folders,
6. Press ok


Actual Results:  Segfault. Base dir created, some files extracted but
a lot missing

Expected Results:  All files extracted...

Additional info:

Works fine when extracted from the command line with tzr -zxf

The problem occurs not only with wine-20031016.tar.gz, but also with
wine-20030115.tar.gz, wine-20030219.tar.gz and so on...
Comment 1 Marco Pesenti Gritti 2004-10-28 05:09:43 EDT
Cannot reproduce on Fedora Core 2. If you are still seeing this issue
please reopen and provide a stack trace of the crash.

Note You need to log in before you can comment on or make changes to this bug.