Bug 110189 - cron misinterprets escaped percent signs
cron misinterprets escaped percent signs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks: 170794
  Show dependency treegraph
 
Reported: 2003-11-16 14:35 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: vixie-cron-4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 18:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-16 14:35:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
cron seems to be misinterpreting backslash-escaped percent sign
characters in commands.  Normally, cron will replace a percent sign in
a command string with a newline.  While preceeding the percent sign
with a backslash prevents this replacement, it leaves the backslash.

Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-76

How reproducible:
Always

Steps to Reproduce:
1. Create a crontab entry such as: 
@reboot date "+Rebooted at \%c" | mail -s reboot root
2. Reboot
3.
    

Actual Results:  root gets email saying:
Rebooted at \Sun Nov 16 13:59:47 2003


Expected Results:  root should get email saying:
Rebooted at Sun Nov 16 13:59:47 2003


Additional info:
Comment 1 Jason Vas Dias 2004-08-04 18:56:42 EDT
fixed in vixie-cron-4.1-+

Note You need to log in before you can comment on or make changes to this bug.