Bug 110194 - Fedora Core 1 up2date/yum repos on fedora.redhat.com not working
Summary: Fedora Core 1 up2date/yum repos on fedora.redhat.com not working
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL: http://fedora.redhat.com/releases/fed...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-16 20:10 UTC by E Chion
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-21 12:57:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified yum.conf (755 bytes, text/plain)
2003-11-17 14:10 UTC, Michael Metz
no flags Details

Description E Chion 2003-11-16 20:10:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
The redirection on
http://fedora.redhat.com/{releases,updates/testing,updates/released}/fedora-core-1
is not working, causing yum, rhn-applet and up2date to report 404 Not
Found errors for all check-update/update/install actions (read: be
totally hosed).


Version-Release number of selected component (if applicable):
FC1

How reproducible:
Always

Steps to Reproduce:
1. Access http://fedora.redhat.com/releases/fedora-core-1
2. Wail (yum check-update)
3. Gnash teeth (up2date upgrade)
    

Actual Results:  Got a pretty 404 page from fedora.redhat.com

Expected Results:  Got redirected to
http://download.fedora.redhat.com/pub/fedora/linux/core/1

Additional info:

Lighting up fedora-list mailing list since Saturday, 15 Nov.

Comment 1 Anders Kaseorg 2003-11-17 01:32:13 UTC
I think it should be a symlink and not a redirection, at least until
bug #110133 is fixed and users have had plenty of time to update
rhn-applet. Otherwise most users will never see another update.

Comment 2 Michael Metz 2003-11-17 14:10:59 UTC
Created attachment 96011 [details]
modified yum.conf

as a workaround you can use the attached yum.conf

Comment 3 Steve Peters 2003-11-17 15:57:18 UTC
For an alternate solution, see ticket 110241

Comment 4 Max Kanat-Alexander 2003-11-20 09:47:26 UTC
This should be RESOLVED FIXED now, from my understanding.

-M

Comment 5 Jeff Johnson 2003-11-21 12:57:24 UTC
OK, fixed as in WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.