Bug 110223 - r-c-network breaks with python 2.3
r-c-network breaks with python 2.3
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-network (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 04:03 EST by Gary Peck
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-07 18:27:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Peck 2003-11-17 04:03:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031015 Firebird/0.7

Description of problem:
redhat-config-network-tui has a dependency on /usr/bin/python2.2.
furthermore, some of its files have a hard-coded path to python2.2
rather than python2 (probably the source of the dependency). this
prevents the installation of the new python packages.

also, before i go on a bug-filing spree, should i report this for
practically every other redhat-config-* tool that has this problem? or
is this being taken care of?

Version-Release number of selected component (if applicable):
1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh python-2.3.2-5.i386.rpm


Actual Results:  error: Failed dependencies:
        /usr/bin/python2.2 is needed by (installed)
redhat-config-rootpassword-1.0.6-2
        /usr/bin/python2.2 is needed by (installed)
redhat-config-soundcard-1.0.8-2
        /usr/bin/python2.2 is needed by (installed)
redhat-config-mouse-1.1.2-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-keyboard-1.1.5-2
        /usr/bin/python2.2 is needed by (installed)
redhat-config-language-1.0.16-1
        /usr/bin/python2.2 is needed by (installed) firstboot-1.2.4-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-samba-1.1.4-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-securitylevel-1.2.11-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-nfs-1.1.3-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-xfree86-0.9.15-1
        /usr/bin/python2.2 is needed by (installed) authconfig-gtk-4.3.8-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-date-1.5.25-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-users-1.2.4-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-network-tui-1.3.10-1
        /usr/bin/python2.2 is needed by (installed)
redhat-config-bind-2.0.1-1
        /usr/bin/python2.2 is needed by (installed) comps-extras-9.1-1
        /usr/bin/python2.2 is needed by (installed) rhpl-0.122.1-2


Additional info:
Comment 1 Gary Peck 2004-01-07 18:27:13 EST
This seems to be fixed in the latest redhat-config-* and
system-config-* packages. Thanks.

Note You need to log in before you can comment on or make changes to this bug.