Bug 11023 - XFree86-devel refuses to install because of cpio error
XFree86-devel refuses to install because of cpio error
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-24 22:51 EDT by compwiz
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 10:56:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description compwiz 2000-04-24 22:51:37 EDT
when trying to upgrade from XFree86-devel 3.3.6 to 4.0-0.8, I get the
following error:

XFree86-devel
#################################################unpacking of archive
failed on file /usr/include/GL: cpio: unlink failed - Bad file descriptor

I'm using rpm 3.0.4-7, and cpio 2.4.2-16. All the other XF 4.0-0.8 rpms
seem to have installed fine.
Comment 1 chris 2000-04-27 12:11:59 EDT
I had exactly the same problem, but it occurred when upgrading XFree86 and
XFree86-xdm from 3.3.6 to 4.0-0.8.  The directories in question were
/usr/X11R6/lib/X11/app-defaults and /etc/X11/xdm/authdir, respectively.
XFree86-devel 4.0-0.8 seemed to work fine.
Comment 2 Anonymous 2000-04-27 21:54:59 EDT
I've had similar problems upgrading from XFree86-3.3.6-20 to XFree86-4.0-0.8 on
a stock RedHat 6.2 system:

[root@eunuchs rawhide]# ls
./                                          XFree86-NeoMagic-4.0-0.8.i386.rpm
XFree86-devel-4.0-0.8.i386.rpm
../                                         XFree86-Rage128-4.0-0.8.i386.rpm
XFree86-doc-4.0-0.8.i386.rpm
XFree86-3DLabs-4.0-0.8.i386.rpm             XFree86-Rendition-4.0-0.8.i386.rpm
XFree86-i740-4.0-0.8.i386.rpm
XFree86-3dfx-4.0-0.8.i386.rpm               XFree86-S3V-4.0-0.8.i386.rpm
XFree86-i810-4.0-0.8.i386.rpm
XFree86-4.0-0.8.i386.rpm                    XFree86-SiS-4.0-0.8.i386.rpm
XFree86-libs-4.0-0.8.i386.rpm
XFree86-ATI-4.0-0.8.i386.rpm                XFree86-TGA-4.0-0.8.i386.rpm
XFree86-mga-4.0-0.8.i386.rpm
XFree86-Alliance-4.0-0.8.i386.rpm           XFree86-Trident-4.0-0.8.i386.rpm
XFree86-tools-4.0-0.8.i386.rpm
XFree86-ChipsTechnologies-4.0-0.8.i386.rpm  XFree86-Tseng-4.0-0.8.i386.rpm
XFree86-twm-4.0-0.8.i386.rpm
XFree86-Cirrus-4.0-0.8.i386.rpm             XFree86-V4L-4.0-0.8.i386.rpm
XFree86-xdm-4.0-0.8.i386.rpm
XFree86-Cyrix-4.0-0.8.i386.rpm              XFree86-VGA16-4.0-0.8.i386.rpm
XFree86-xf86cfg-4.0-0.8.i386.rpm
XFree86-FBDev-4.0-0.8.i386.rpm              XFree86-Xnest-4.0-0.8.i386.rpm
XFree86-xfs-4.0-0.8.i386.rpm
XFree86-NVidia-4.0-0.8.i386.rpm             XFree86-Xvfb-4.0-0.8.i386.rpm

[root@eunuchs rawhide]# rpm -Uvh --nodeps --force *.rpm
XFree86-3DLabs              ##################################################
XFree86-3dfx                ##################################################
XFree86                     ###################unpacking of archive failed on
file /usr/X11R6/lib/X11/app-defaults: cpio: unlink failed - Bad file desc
riptor
XFree86-ATI                 ##################################################
XFree86-Alliance            ##################################################
XFree86-ChipsTechnologies   ##################################################
XFree86-Cirrus              ##################################################
XFree86-Cyrix               ##################################################
XFree86-FBDev               ##################################################
XFree86-NVidia              ##################################################
XFree86-NeoMagic            ##################################################
XFree86-Rage128             ##################################################
XFree86-Rendition           ##################################################
XFree86-S3V                 ##################################################
XFree86-SiS                 ##################################################
XFree86-TGA                 ##################################################
XFree86-Trident             ##################################################
XFree86-Tseng               ##################################################
XFree86-V4L    ##################################################
XFree86-VGA16               ##################################################
XFree86-Xnest               ##################################################
XFree86-Xvfb                ##################################################
XFree86-devel               ##################################################
package Xthreads.h not found in file index
package svr4.cf not found in file index
XFree86-doc                 ##################################################
XFree86-i740                ##################################################
XFree86-i810                ##################################################
cannot read packages named XFree86-Cyrix for uninstall
Segmentation fault (core dumped)
Comment 3 Sammy 2000-05-01 15:19:59 EDT
This is because of bug 11080......one of the rpm's in -0.8 is tarring
the entire system under /var/state/xkb ....this fills the /var partition
and you get the error you see!
Comment 4 Preston Brown 2000-05-08 10:56:59 EDT
the current XFree86 4.0 RPM is very screwed up, please don't use it.  We are
working on the problems.
Comment 5 SB 2000-05-14 19:10:59 EDT
After failing to install it, X no longer works and your chance of using X again
are pretty slim.  I did however install it successfully on my system by using
this method, and don't cringe yet, the workaround isn't time-consuming at all:

Follow these steps and you should do fine:
[root@king apr24]# cp XFree86-4.0-0.8.i386.rpm /tmp/
[root@king apr24]# cd /tmp
[root@king /tmp]# rpm2cpio XFree86-4.0-0.8.i386.rpm > XFree86-4.0-0.8.cpio
[root@king /tmp]# cpio -idm < XFree86-4.0-0.8.i386.rpm.cpio
30723 blocks
[root@king /tmp]# l
drwx------    3 root     root         1024 May 14 19:06 etc
drwx------    3 root     root         1024 May 14 19:06 usr
drwx------    3 root     root         1024 May 14 19:06 var

Ok now you have all the XFree86 4.0 files in their hierarchy located in the /tmp
dir.  Now the annoying part: Move the files from /tmp/etc /tmp/usr and /tmp/var
to their correct locations in /etc /usr and /var, it's actually not too tough.
I only recommend doing this if you tried to upgrade a previous version of
XFree86 and failed which left you unable to reinstall XFree86 due to the
conflicts and mess the failed install did.  Before you go and try this by hand
like I've suggested try a rpm --test XFree86-4.0-0.8.i386.rpm to make sure there
are no conflicts with older packages you may screw up by doing it this way.  I
don't recommend installing X this way it is just the way that worked well for me
and I'm only suggesting it in case some of you are tha desperate.

Hope that was helpful, and the usual don't try this at home I'm not resonsible
stuff applies ;)

-Stan Bubrouski

Note You need to log in before you can comment on or make changes to this bug.