Bug 110242 - busybox-1 doesn't have lsmod support
busybox-1 doesn't have lsmod support
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: busybox (Show other bugs)
1.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 10:01 EST by Karsten Hopp
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 05:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix lsmod support, disable colored ls (4.95 KB, text/plain)
2003-11-19 08:25 EST, Karsten Hopp
no flags Details
fix wrong define, it has been renamed (351 bytes, patch)
2003-11-19 08:26 EST, Karsten Hopp
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2003-11-17 10:01:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1)
Gecko/20031030

Description of problem:
you could symlink older busybox versions to lsmod and it used to work
such as the real lsmod. busybox-1 just prints out a list of supported
commands.

Version-Release number of selected component (if applicable):
busybox-1.00-2

How reproducible:
Always

Steps to Reproduce:
1. ln -s busybox lsmod
2. ./lsmod
3. no list of loaded modules
    

Actual Results:  busybox-1 just prints out a list of supported commands.

Expected Results:  should print out list of loaded modules, even
something similar to  'cat /proc/modules' would do.

Additional info:

unnecessary regression, would be a 'nice to have'
Comment 1 Kaj J. Niemi 2003-11-17 11:48:50 EST
The busybox-static binary is able to handle lsmod but busybox built
for anaconda isn't.

[1 d107 /usr/src/redhat/BUILD/busybox-1.00]% ln busybox-static lsmod
[d107 /usr/src/redhat/BUILD/busybox-1.00]% ./lsmod
Module                  Size  Used by    Not tainted
[ ... ]

[d107 /usr/src/redhat/BUILD/busybox-1.00]% ln -s busybox lsmod
[d107 /usr/src/redhat/BUILD/busybox-1.00]% ./lsmod
BusyBox v1.00-pre2 (2003.11.17-16:28+0000) multi-call binary
 
Usage: busybox [function] [arguments]...
   or: [function] [arguments]...


QuickHack(tm) is to add

perl -pi -e 's/^# CONFIG_LSMOD.*/CONFIG_LSMOD=y/g;'
sysdeps/linux/defconfig

above "make DOLFS=y defconfig" in the %%build section of busybox.spec.

[@d107 /usr/src/redhat/BUILD/busybox-1.00]% !ln
ln busybox lsmod
[d107 /usr/src/redhat/BUILD/busybox-1.00]% ./lsmod
Module                  Size  Used by    Not tainted
[ ... ]

Comment 2 Karsten Hopp 2003-11-19 08:22:49 EST
It looks like the defconfig files are from older busybox versions, 
many options are missing. Try to copy them to .config in the main 
directory and run 'make oldconfig' and you'll see. 
I'll attach an updated -anaconda patch and a new -s390 patch to fix 
a wrong define. 
Comment 3 Karsten Hopp 2003-11-19 08:25:22 EST
Created attachment 96055 [details]
fix lsmod support, disable colored ls

patch to fix lsmod support and to disable colored ls (better fix would be to
check the terminal capabilities)
Comment 4 Karsten Hopp 2003-11-19 08:26:17 EST
Created attachment 96056 [details]
fix wrong define, it has been renamed
Comment 5 Daniel Walsh 2004-03-25 11:03:19 EST
Check out busybox-pre8 from rawhide and see if it fixes the problem.
Comment 6 Karsten Hopp 2004-06-14 05:49:07 EDT
current busybox looks ok to me 

Note You need to log in before you can comment on or make changes to this bug.