Bug 110244 - g++ crash compiling lufs
g++ crash compiling lufs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
: 113906 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 10:06 EST by Paul Rensing
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 09:36:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Rensing 2003-11-17 10:06:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
While compiling the lufs package, g++ segfaults.

I am trying to compile lufs version 0.9.7 for Fedora 1. When trying to
compile filesystems/sshfs/sshfs.cpp, I get:

 g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../
-I/scratch/rpms/BUILD/lufs-0.9.7/include -O2 -Wall
-DSSHPROG=\"/usr/bin/ssh\" -O2 -Wall -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -MT sshfs.lo -MD -MP -MF .deps/sshfs.Tpo -c
sshfs.cpp  -fPIC -DPIC -o .libs/sshfs.o
g++: Internal error: Segmentation fault (program cc1plus)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.


I am running on a 686 box with Fedora up to date. I used a slightly
modified version of the "lufs.spec" file that came in the tarball (had
to update the version number and remove the listed patch file).

I believe I got the same thing if I just did "configure" and then "make".

I got lufs off SourceForge at:
http://sourceforge.net/project/showfiles.php?group_id=57332



Version-Release number of selected component (if applicable):
gcc-3.3.2-1

How reproducible:
Always

Steps to Reproduce:
1.fetch lufs 0.9.7
2.configure
3.make
    

Actual Results:   g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../
-I/scratch/rpms/BUILD/lufs-0.9.7/include -O2 -Wall
-DSSHPROG=\"/usr/bin/ssh\" -O2 -Wall -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -MT sshfs.lo -MD -MP -MF .deps/sshfs.Tpo -c
sshfs.cpp  -fPIC -DPIC -o .libs/sshfs.o
g++: Internal error: Segmentation fault (program cc1plus)


Additional info:
Comment 1 Walter Mundt 2004-03-12 11:38:30 EST
I encountered this as well.  If you want LUFS but don't need sshfs
support, you can work around this by forcing it to build without
sshfs.  The only way I've found to do this is by specifying an invalid
path to ssh as a configure option.  e.g. run './configure
--with-ssh=/blarg && make'.  This builds properly.
Comment 2 Edward Macnaghten 2004-05-30 16:54:36 EDT
Managed to get round it

In filesystems/sshfs/sshfs.cpp

At line 478 (I think)

Change

    handles.push_back((struct atbl){string(file), handle, time(NULL),
mode});

to

    struct atbl aa = {string(file), handle, time(NULL), mode} ;
                                                                     
                                                                     
                
    handles.push_back(aa);

There are probably more sllick solutions but it worked for me :)
Comment 3 Edward Macnaghten 2004-05-30 17:14:15 EDT
Follow up on prev post

Correction - Line 348 of filesystems/sshfs/sshfs.cpp - Sorry


Change

    handles.push_back((struct atbl){string(file), handle, time(NULL),
mode});

to

    struct atbl aa = {string(file), handle, time(NULL), mode} ;
    handles.push_back(aa);

Comment 4 Richard Henderson 2004-10-04 03:51:19 EDT
Having spent the better part of two hours trying to get lufs to
even configure properly, I'm not willing to persue this further
unless someone provides a preprocessed version of sshfs.cpp.
Comment 5 Richard Henderson 2004-10-04 04:31:02 EDT
*** Bug 113906 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Jelinek 2004-11-24 09:36:56 EST
If you have sshfs.ii, please reopen.

Note You need to log in before you can comment on or make changes to this bug.