Bug 110253 - nfs does not mount on bot as netfs parses /etc/fstab before nic has completed auto-neg,
nfs does not mount on bot as netfs parses /etc/fstab before nic has completed...
Status: CLOSED DUPLICATE of bug 107999
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 11:59 EST by danny
Modified: 2014-03-16 22:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description danny 2003-11-17 11:59:37 EST
Description of problem:
netfs attempts to mount nfs shares whilst nic is still 
autonegotiating port speed.


Version-Release number of selected component (if applicable):
redhat es 3

How reproducible:
every time


Steps to Reproduce:
1. boot server
2.
3.
  
Actual results:
no nfs mounts, error is rpc no route to host


Expected results:
nfs mounts should be mounted 


Additional info:
a sleep in netfs of a couple of seconds fixes this. The netfs init 
script should test the network interface has completed autoneg before 
trying to mount nfs shares, or indeed perform any network dependant 
actions.

This happens on all our ES boxes built on standard  HP DL360/DL380 
servers connected to a cisco switch infrastructure.
Comment 1 Bill Nottingham 2003-11-17 14:53:40 EST
Static IPs?
Comment 2 danny 2003-11-17 15:08:19 EST
The machine has two static ip address's, 1 bound to each Nic. The 
problem appears to be:

ifconfig plumbs the Nics, this then exits, our portmap is started and 
netfs attempts to mount the nfs share. Unfortunately the nics whilst 
up are still negotiating the connection media, 100 full 100 half 10 
half etc, by the time they have negotiated a media the nfs shares 
have failed to mount.
When the box has finished booting the nics have negotioated a medium. 
meaning I can login and manually mount the share using fstab. ie 
mount /www/.


Comment 3 Eric Eisenhart 2003-12-10 14:34:27 EST
I believe this is the same basic problem as in 107999; I attached a
workaround there.
Comment 4 Bill Nottingham 2003-12-10 15:09:10 EST

*** This bug has been marked as a duplicate of 107999 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.