Bug 110254 - up2date crashes with 'up2dateErros' is not defined
up2date crashes with 'up2dateErros' is not defined
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 112403 113549 113742 114043 115487 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 12:00 EST by Michael Young
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version: 4.3.11-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 12:31:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2003-11-17 12:00:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I have had a crash with up2date giving this traceback
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 2070, in
doInstallation
    kernelsToInstall = up2date.installPackages(self.selectedPkgList,
self.rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 619, in
installPackages
    raise up2dateErros.RpmError("%s" % e)
NameError: global name 'up2dateErros' is not defined
during the download phase. A don't know what the problem was, but at
the very least it looks like you have a typo. A second run has got
past the crash point.
This is with 4.1.16-1.
Comment 1 Miloslav Trmac 2003-11-20 12:45:04 EST
Triage->Easyfix

(s/up2dateErros/up2dateErrors/)
Comment 2 Tammy Fox 2004-01-17 21:08:21 EST
*** Bug 112403 has been marked as a duplicate of this bug. ***
Comment 3 Tammy Fox 2004-01-18 13:40:15 EST
Yep. I get this traceback as well but was able to fix it by changing
'up2dateErros' to 'up2dateErrors' in
/usr/share/rhn/up2date_client/up2date.py.
Comment 4 Aleksey Nogin 2004-01-19 00:21:46 EST
*** Bug 113549 has been marked as a duplicate of this bug. ***
Comment 5 Aleksey Nogin 2004-01-19 00:22:22 EST
*** Bug 113742 has been marked as a duplicate of this bug. ***
Comment 6 Adrian Likins 2004-01-20 14:22:25 EST
fixed in cvs
Comment 7 Adrian Likins 2004-01-20 14:59:32 EST
probabaly should land in rawhide in 4.3.9
Comment 8 Jef Spaleta 2004-01-28 12:23:24 EST
*** Bug 114043 has been marked as a duplicate of this bug. ***
Comment 9 Miloslav Trmac 2004-02-03 12:31:05 EST
Fix confirmed in up2date-4.3.11-2.
Comment 10 Miloslav Trmac 2004-02-13 07:19:41 EST
*** Bug 115487 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.