Bug 110262 - GDB lacks support to debug XFree86
Summary: GDB lacks support to debug XFree86
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gdb   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 233751
TreeView+ depends on / blocked
 
Reported: 2003-11-17 17:41 UTC by Jesse Keating
Modified: 2015-01-08 00:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 17:25:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2003-11-17 17:41:25 UTC
Description of problem:
I'm trying to debug some XFree86 issues I'm having with the Radeon
driver, and I've found that gdb lacks the ability to debug XFree86. 
We found a debugger that worked in RHL8, x86 hardware from
people.redhat.com, but we'd like to move the cluster to RHEL3.  I'd
like to file an RFE to have RHEL3's debugger be able to debug XFree86.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL3
2. Experience XFree86 problems with Radeon DRI
3. Attempt to debug XFree86
    

Actual Results:  Unable to debug, gdb has not the capability.

Expected Results:  The ability to debug XFree86 using gdb.

Comment 1 Suzanne Hillman 2003-11-17 21:02:22 UTC
RFE logged as internal bug #110283 - will consider for future releases.

Comment 2 Jesse Keating 2003-11-17 21:04:33 UTC
Is that future RHEL releases, or future gdb releases?

Comment 3 Jan Kratochvil 2007-03-24 17:25:18 UTC
RHEL3 and RHEL4 were IIRC using for X the custom crossplatform driver loaded (.o
based) and so a specific GDB support would be needed.
Since RHEL5 Xorg uses a standard mapped .so libraries where no specific GDB
support is needed.
RHEL3.9 is being closed now and while no 3ACK process was applied to this Bug
there is not much time left to consider its implementation.
I also believe it is not worth the implementation without any ITs and the
functionality limitation only to RHEL3/RHEL4 now.



Note You need to log in before you can comment on or make changes to this bug.