Bug 110263 - 'sysctl' is linked against too much libraries; should not need /usr/lib
Summary: 'sysctl' is linked against too much libraries; should not need /usr/lib
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: procps   
(Show other bugs)
Version: 1.0
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-17 18:12 UTC by Enrico Scholz
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 13:59:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2003-11-17 18:12:19 UTC
Description of problem:

'sysctl' is linked against libgpm and libncurses:

| $ ldd /sbin/sysctl
|         libproc.so.2.0.17 => /lib/libproc.so.2.0.17 (0x40032000)
|         libncurses.so.5 => /usr/lib/libncurses.so.5 (0x4003f000)
|         libselinux.so.1 => /lib/libselinux.so.1 (0x4007f000)
|         libc.so.6 => /lib/i686/libc.so.6 (0x40086000)
|         libgpm.so.1 => /usr/lib/libgpm.so.1 (0x401c1000)
|         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
|         libm.so.6 => /lib/i686/libm.so.6 (0x401c7000)

Since sysctl is started very early (before e.g. NFS is started), this
causes problems when /usr is NFS-shared (at least with 'libncurses').
Then sysctl fails to run and important kernel variables will not be
initialized so that e.g. network fails to start.


Version-Release number of selected component (if applicable):

procps-2.0.17-3.sel

Comment 1 Sammy 2004-01-09 17:12:17 UTC
This is still a problem as of Jan 9, 2004 development. Machines that 
have a saperate /usr partitition give an error messsage during boot 
when running sysctl. 

Comment 2 Daniel Walsh 2004-02-11 13:59:11 UTC
Fixed in 3.1.15


Note You need to log in before you can comment on or make changes to this bug.