Bug 110265 - rc.sysinit's cleanup of /var/run don't like vmware directories
rc.sysinit's cleanup of /var/run don't like vmware directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Patch
: 114672 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 13:16 EST by Peter Bieringer
Modified: 2014-03-16 22:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: 7.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 21:45:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2003-11-17 13:16:19 EST
Description of problem:
Using VMwareWorkstation-4.0.5-6030 here, on booting,
/etc/rc.d/rc.sysinit reports:

rm: cannot remove `/var/run/vmware/peter/10575': Is a directory
rm: cannot remove `/var/run/vmware/peter/13004': Is a directory
rm: cannot remove `/var/run/vmware/peter/15684': Is a directory
rm: cannot remove `/var/run/vmware/peter/18837': Is a directory
rm: cannot remove `/var/run/vmware/peter/vmx_10575': Is a directory
rm: cannot remove `/var/run/vmware/peter/vmx_13004': Is a directory
rm: cannot remove `/var/run/vmware/peter/vmx_15684': Is a directory
rm: cannot remove `/var/run/vmware/peter/vmx_18837': Is a directory


This also happens on RHL 7.3 afair

Version-Release number of selected component (if applicable):
initscripts-7.42-1

How reproducible:
Always

Steps to Reproduce:
1. Use VMwareWorkstation-4.*
2. Reboot
    

Actual Results:  Report of unremovable files like shown above

Expected Results:  No such messages

Additional info:

Following fix helps:

--- rc.sysinit.fedoraorig       2003-11-16 14:45:01.000000000 +0100
+++ rc.sysinit  2003-11-17 19:08:09.000000000 +0100
@@ -647,7 +647,8 @@
        if [ -d "$afile" ]; then
           case "$afile" in
                */news|*/mon)   ;;
-               */sudo|*/vmware)        rm -f $afile/*/* ;;
+               */sudo) rm -f $afile/*/* ;;
+               */vmware)       rm -rf $afile/*/* ;;
                *)              rm -f $afile/* ;;
           esac
        else
Comment 1 Miloslav Trmac 2003-11-20 12:50:15 EST
Triage->Easyfix
Comment 2 Leonard den Ottolander 2004-02-05 09:22:48 EST
Bug #114672 seems to be a duplicate of this one.
Comment 3 Bill Nottingham 2004-02-05 10:19:55 EST
*** Bug 114672 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2004-03-16 21:45:44 EST
Added in 7.47-1.

Note You need to log in before you can comment on or make changes to this bug.