This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 110278 - up2date is not recognizing packages as needing updating
up2date is not recognizing packages as needing updating
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 15:11 EST by Christopher Stone
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 17:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2003-11-17 15:11:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
since the release of fedora core 1 (it was working with the test
releases), up2date has not been able to recognize that packages I have
installed from RH9 need updating.  These packages are the kernel RPMs
and rp-pppoe (these are the only packages I have not updated from
RH9).  yum correctly sees these packages as needing updating:

# yum check-update
Gathering header information file(s) from server(s)
Server: Fedora.us-stable
Server: Fedora Core 1 - i386 - Base
Server: Livna.org Fedora Compatible Packages (stable)
Server: Red Hat Linux 9 NewRPMS.sunsite.dk
Server: Fedora Core 1 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Name                                Arch   Version                  Repo
--------------------------------------------------------------------------------
kernel                              i686   2.4.22-1.2115.nptl       base
kernel-doc                          i386   2.4.22-1.2115.nptl       base
kernel-source                       i386   2.4.22-1.2115.nptl       base
kernel-utils                        i386   1:2.4-9.1.101.fedora     base
rp-pppoe                            i386   3.5-8                    base

however up2date does not see these packages as needing updating.  This
problem first started to occur with the release of fedora core 1 (it
worked properly with test 3).

Version-Release number of selected component (if applicable):
up2date-4.1.16-1

How reproducible:
Always

Steps to Reproduce:
run up2date with a package from RH9
    

Actual Results:  up2date does not recognize the RH9 package as needing
updating

Expected Results:  up2date should recognize the old packages are
suggest an upgrade

Additional info:

my /etc/sysconfig/rhn/sources file contains:

yum fedora-core-1
http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os
yum updates-released
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386

Note You need to log in before you can comment on or make changes to this bug.