Bug 110290 - Latest glibc update breaks gnome/X
Latest glibc update breaks gnome/X
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-11-17 17:52 EST by John Ketchum
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-25 17:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Ketchum 2003-11-17 17:52:11 EST
Description of problem:
After installing the latest versions of glibc and related rpms:
(also tried forcing glibc-2.3.2-4.80.8.i686.rpm, which didn't make 
any difference)
I observed the following symptoms:
When attempting to log on to Gnome, the system froze in the login 
process at the transitional screen between the login prompt and the 
desktop, for 3-4 minutes, then completed the login process showing 
the Gnome desktop,with the Workspace Switcher missing. When I started 
an X application like xterm or xemacs, it came up in the upper left 
ahnd corner of the screen in a non-resizable, non-movable window. 
With more than one x app up, there was no way to switch betwee napp 

I could log in remotely, but if I tried to run an X app, like Xemacs, 
from the remote host, it didn't display on the remote host, and after 
several minutes, the terminal session froze and was terminated.

I fixed the problem by forcing an install of the previous versions of 
the above rpms (glibc-2.3.2-4.80.6.i686.rpm, etc., and postgresql-
libs--7.2.3-5.80.i386.rpm) --- 
rpm -Uvh --force glibc-2.3.2-4.80.6.i686.rpm .........
After doing this, Gnome is behaving normally again.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install lates glibc and related packages, as above
2.login to Gnome
3.run xterm or xemacs
Actual results:
Gnome is broken

Expected results:
Normal operation of Gnome

Additional info:
Comment 1 Andrew Lare 2003-11-26 12:58:13 EST
I had the exact same thing happen on one of my systems.  Three others
are not exhibiting any difficulty, but I had to do the same workaround
on the affected system.  One precursor (maybe) that I noticed on the
affected system occurred after patch installation:

Starting OpenOffice.org ...
/usr/lib/openoffice/program/soffice.bin: relocation error:
/usr/lib/openoffice/program/libvcl641li.so: undefined symbol:

Ngnome-calculator: relocation error: /usr/lib/libXft.so.2: undefined
symbol: FT_Set_Hint_Flags

Once I reinstalled the previous glibc version, these errors
disappeared as well.
Comment 2 Ulrich Drepper 2004-08-26 00:36:28 EDT
We definitely have never heard about any issues like that with any of
the updates.  People would have complaint a lot.

The FT_Set_Hint_flags thing points to freetype.  Maybe an
incompatibility in the versions you were using.  It might be that the
problem was previously hidden by a bug in glibc, but if the new
version says the symbol is missing, I trust that.  You can see for
yourself, run

  readelf -s /usr/lib/freetype.so | fgrep FT_Set_Hint_Flags

I'll close the bug shortly unless substantial evidence is shown that
there is something wrong in *today's* glibc code.

Most compatibility problems attributed to glibc are bugs in
applications which are exposed by glibc.
Comment 3 Ulrich Drepper 2004-09-25 17:03:12 EDT
Closing the bug.  No response received and it seems to be unrelated to
glibc in any case.

Note You need to log in before you can comment on or make changes to this bug.