Bug 110291 - logwatch hostname pattern match in cron analysis
logwatch hostname pattern match in cron analysis
Status: CLOSED DUPLICATE of bug 109498
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-11-17 18:05 EST by Need Real Name
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Correction to pattern match for hostname field (538 bytes, patch)
2003-11-17 18:07 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2003-11-17 18:05:47 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux) 
Description of problem: 
The hostname pattern match in /etc/log.d/scripts/services/cron is incorrect.  Any host 
which contains the character '-' in its name will get unmatched entries for things 
which would be otherwise ignored. 
Version-Release number of selected component (if applicable): 
How reproducible: 
Steps to Reproduce: 
1. Install redhat 9 on a host with a minus in its name (e.g. host-1.example.com) 
2. Wait until there are entries for cron.hourly in /var/log/cron 
3. Run /etc/cron.daily/00-logwatch 
Actual Results:  You will see unmatched entries for 'cron.hourly' runs in the email 
output by logwatch.  These entries are correctly skipped if the hostname does not 
contain a minus. 
Expected Results:  Invocations of cron.hourly should not show up in the email output 
by logwatch.
Comment 1 Need Real Name 2003-11-17 18:07:40 EST
Created attachment 96035 [details]
Correction to pattern match for hostname field
Comment 2 Miloslav Trmac 2003-11-20 12:55:32 EST
Comment 3 Elliot Lee 2003-12-17 14:45:35 EST

*** This bug has been marked as a duplicate of 109498 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.