Bug 110293 - xfree86 update gives error on install
xfree86 update gives error on install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 18:54 EST by David Kaplan
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 10:32:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2003-11-17 18:54:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
Upon upgrade of xfree86 using apt and fedora repositories, I got the
following error message on install:

Get:3 http://download.fedora.us redhat/9/i386/updates XFree86
4.3.0-2.90.43 [13.
2MB]
...
3:XFree86 ########################################### [ 16%]
/var/tmp/rpm-tmp.34041: line 1: xftcache: command not found


Version-Release number of selected component (if applicable):
XFree86-4.3.0-2.90.43

How reproducible:
Didn't try


Additional info:
Comment 1 Mike A. Harris 2004-09-23 10:32:53 EDT
This is a known bug in the ttfonts package from Red Hat Linux
7.x releases, which have a trigger script in them that runs
xftcache without checking to see if the command exists.  The
trigger kicks in whenever XFree86 gets upgraded.  So if you
have this old ttfonts package installed and upgrade, you will
always get this error, and there is no way around it other
than to manually uninstall the ttfonts package before
upgrading.

A later version of the faulty package fixed the problem by
removing the trigger and replacing it with the correct code
in a %post/postun script, however due to the nature of trigger
scripts, they always get activated on upgrades (or whatever
the trigger is set to), so even if you upgrade the package,
the script will get triggered and the error will occur on systems
that no longer have xftcache.

As such, due to the ttfonts packaging bug, it's not possible to
avoid seeing this error, however the error is totally harmless
and will not affect the running system afterward, so it can
be safely ignored.

Setting status to "CURRENTRELEASE" as this problem is not
present in our current Fedora Core 2 release.  If you upgrade
from RHL 7.x to Fedora Core 2 you may see this harmless error
still however.

Note You need to log in before you can comment on or make changes to this bug.